summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2006-10-23 20:12:26 +0000
committerFrancesco Riosa <vivo@gentoo.org>2006-10-23 20:12:26 +0000
commit02127f0fe00427a6c3680e77690bbf30ba341209 (patch)
tree6c49df3cae52341b7d6ccde4ba574841c2f96ca2 /mail-filter
parentfix for bug #150279 - missing scripts (diff)
downloadgentoo-2-02127f0fe00427a6c3680e77690bbf30ba341209.tar.gz
gentoo-2-02127f0fe00427a6c3680e77690bbf30ba341209.tar.bz2
gentoo-2-02127f0fe00427a6c3680e77690bbf30ba341209.zip
Added warning to use "latin1" in MySQL as default charset
(Portage version: 2.1.1)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/sqlgrey/ChangeLog5
-rw-r--r--mail-filter/sqlgrey/sqlgrey-1.6.7.ebuild10
-rw-r--r--mail-filter/sqlgrey/sqlgrey-1.7.4.ebuild11
3 files changed, 17 insertions, 9 deletions
diff --git a/mail-filter/sqlgrey/ChangeLog b/mail-filter/sqlgrey/ChangeLog
index 0d6a53b48eec..871037c8400d 100644
--- a/mail-filter/sqlgrey/ChangeLog
+++ b/mail-filter/sqlgrey/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-filter/sqlgrey
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/sqlgrey/ChangeLog,v 1.2 2006/10/22 13:49:57 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/sqlgrey/ChangeLog,v 1.3 2006/10/23 20:12:26 vivo Exp $
+
+ 23 Oct 2006; <vivo@gentoo.org> sqlgrey-1.6.7.ebuild, sqlgrey-1.7.4.ebuild:
+ Added warning to use "latin1" in MySQL as default charset
22 Oct 2006; Francesco Riosa <vivo@gentoo.org> sqlgrey-1.6.7.ebuild,
sqlgrey-1.7.4.ebuild:
diff --git a/mail-filter/sqlgrey/sqlgrey-1.6.7.ebuild b/mail-filter/sqlgrey/sqlgrey-1.6.7.ebuild
index 2e7e3ceb87d5..977bb6e2a912 100644
--- a/mail-filter/sqlgrey/sqlgrey-1.6.7.ebuild
+++ b/mail-filter/sqlgrey/sqlgrey-1.6.7.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation# Distributed under the terms of the GNU General Public License v2
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/sqlgrey/sqlgrey-1.6.7.ebuild,v 1.2 2006/10/22 13:49:57 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/sqlgrey/sqlgrey-1.6.7.ebuild,v 1.3 2006/10/23 20:12:26 vivo Exp $
inherit eutils
DESCRIPTION="SQLgrey is a postfix policy service implementing a grey-listing policy"
-SRC_URI="mirror://sourceforge/sqlgrey/${PN}-${PV}.tar.bz2"
+SRC_URI="mirror://sourceforge/sqlgrey/${P}.tar.bz2"
HOMEPAGE="http://sqlgrey.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
@@ -54,10 +54,12 @@ pkg_postinst() {
einfo
echo
einfo "To setup SQLgrey to run out-of-the-box on your system, run:"
- einfo "emerge --config ${PF}"
+ einfo "emerge --config ${PN}"
echo
ewarn "Read the documentation for more info (perldoc sqlgrey) or the"
ewarn "included howto /usr/share/doc/${PF}/HOWTO.gz"
+ ewarn "If you are using MySQL >= 4.1 use \"latin1\" as charset for"
+ ewarn "the SQLgrey db"
echo
ebeep 2
epause 5
@@ -222,7 +224,7 @@ pkg_config () {
einfo "Creating SQLgrey MySQL database \"${SQLgrey_DB_NAME}\" and user \"${SQLgrey_DB_USER_NAME}\""
echo -ne " "
- /usr/bin/mysql -u root -h ${SQLgrey_DB_HOST} -p -e "CREATE DATABASE IF NOT EXISTS ${SQLgrey_DB_NAME}; GRANT ALL ON ${SQLgrey_DB_NAME}.* TO ${SQLgrey_DB_USER_NAME}@${SQLgrey_DB_HOST} IDENTIFIED BY '${SQLgrey_DB_USER_PWD}';FLUSH PRIVILEGES;" -D mysql
+ /usr/bin/mysql -u root -h ${SQLgrey_DB_HOST} -p -e "CREATE DATABASE IF NOT EXISTS ${SQLgrey_DB_NAME} CHARACTER SET latin1; GRANT ALL ON ${SQLgrey_DB_NAME}.* TO ${SQLgrey_DB_USER_NAME}@${SQLgrey_DB_HOST} IDENTIFIED BY '${SQLgrey_DB_USER_PWD}';FLUSH PRIVILEGES;" -D mysql
echo
einfo "Changing SQLgrey configuration in sqlgrey.conf"
diff --git a/mail-filter/sqlgrey/sqlgrey-1.7.4.ebuild b/mail-filter/sqlgrey/sqlgrey-1.7.4.ebuild
index d38bde38d282..07445f924ee1 100644
--- a/mail-filter/sqlgrey/sqlgrey-1.7.4.ebuild
+++ b/mail-filter/sqlgrey/sqlgrey-1.7.4.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation# Distributed under the terms of the GNU General Public License v2
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/sqlgrey/sqlgrey-1.7.4.ebuild,v 1.2 2006/10/22 13:49:57 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/sqlgrey/sqlgrey-1.7.4.ebuild,v 1.3 2006/10/23 20:12:26 vivo Exp $
inherit eutils
DESCRIPTION="SQLgrey is a postfix policy service implementing a grey-listing policy"
-SRC_URI="mirror://sourceforge/sqlgrey/${PN}-${PV}.tar.bz2"
+SRC_URI="mirror://sourceforge/sqlgrey/${P}.tar.bz2"
HOMEPAGE="http://sqlgrey.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
@@ -54,11 +54,14 @@ pkg_postinst() {
einfo
echo
einfo "To setup SQLgrey to run out-of-the-box on your system, run:"
- einfo "emerge --config ${PF}"
+ einfo "emerge --config ${PN}"
echo
ewarn "Read the documentation for more info (perldoc sqlgrey) or the"
ewarn "included howto /usr/share/doc/${PF}/HOWTO.gz"
echo
+ ewarn "If you are using MySQL >= 4.1 use \"latin1\" as charset for"
+ ewarn "the SQLgrey db"
+ echo
ebeep 2
epause 5
}
@@ -222,7 +225,7 @@ pkg_config () {
einfo "Creating SQLgrey MySQL database \"${SQLgrey_DB_NAME}\" and user \"${SQLgrey_DB_USER_NAME}\""
echo -ne " "
- /usr/bin/mysql -u root -h ${SQLgrey_DB_HOST} -p -e "CREATE DATABASE IF NOT EXISTS ${SQLgrey_DB_NAME}; GRANT ALL ON ${SQLgrey_DB_NAME}.* TO ${SQLgrey_DB_USER_NAME}@${SQLgrey_DB_HOST} IDENTIFIED BY '${SQLgrey_DB_USER_PWD}';FLUSH PRIVILEGES;" -D mysql
+ /usr/bin/mysql -u root -h ${SQLgrey_DB_HOST} -p -e "CREATE DATABASE IF NOT EXISTS ${SQLgrey_DB_NAME} CHARACTER SET latin1; GRANT ALL ON ${SQLgrey_DB_NAME}.* TO ${SQLgrey_DB_USER_NAME}@${SQLgrey_DB_HOST} IDENTIFIED BY '${SQLgrey_DB_USER_PWD}';FLUSH PRIVILEGES;" -D mysql
echo
einfo "Changing SQLgrey configuration in sqlgrey.conf"