summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-12 09:05:03 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-12 09:05:03 +0000
commit077c4c8b7057378d3a006673e3c71a0c4dd49441 (patch)
tree4a0beee7c45f644c294859944eb8cd53bbc2950b /mail-filter/p3scan
parentStop using ${LDFLAGS} inside LDFLAGS="" because of dev-libs/boost-build and w... (diff)
downloadgentoo-2-077c4c8b7057378d3a006673e3c71a0c4dd49441.tar.gz
gentoo-2-077c4c8b7057378d3a006673e3c71a0c4dd49441.tar.bz2
gentoo-2-077c4c8b7057378d3a006673e3c71a0c4dd49441.zip
Revbump which fixes CC/C{XX}FLAGS/LDFLAGS. Unbundles ripmime library. Bug #244144. Thanks to Kevin Pyle
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter/p3scan')
-rw-r--r--mail-filter/p3scan/ChangeLog12
-rw-r--r--mail-filter/p3scan/p3scan-2.3.2-r1.ebuild101
2 files changed, 111 insertions, 2 deletions
diff --git a/mail-filter/p3scan/ChangeLog b/mail-filter/p3scan/ChangeLog
index 6019c5521efe..48ce46df5922 100644
--- a/mail-filter/p3scan/ChangeLog
+++ b/mail-filter/p3scan/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-filter/p3scan
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/p3scan/ChangeLog,v 1.14 2009/05/16 00:39:52 halcy0n Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/p3scan/ChangeLog,v 1.15 2010/07/12 09:05:02 hwoarang Exp $
+
+*p3scan-2.3.2-r1 (12 Jul 2010)
+
+ 12 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+ +p3scan-2.3.2-r1.ebuild:
+ Rebump which fixes CC/C{XX}FLAGS/LDFLAGS. Unbundles ripmime library.
+ Fixes bug #244144. Many thanks to Kevin Pyle for all the work
+ and the patches he provided
16 May 2009; Mark Loeser <halcy0n@gentoo.org> p3scan-2.3.2.ebuild:
Fix elog statement; bug #260792
diff --git a/mail-filter/p3scan/p3scan-2.3.2-r1.ebuild b/mail-filter/p3scan/p3scan-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..ce8e0853d00f
--- /dev/null
+++ b/mail-filter/p3scan/p3scan-2.3.2-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/p3scan/p3scan-2.3.2-r1.ebuild,v 1.1 2010/07/12 09:05:03 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="This is a full-transparent proxy-server for POP3-Clients."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://p3scan.sf.net/"
+
+# Older ripmime did not install a library
+DEPEND="dev-libs/libpcre
+ >=net-mail/ripmime-1.4.0.9
+ "
+RDEPEND="net-firewall/iptables"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/p3scan-ocreat.patch"
+
+ # respect CC (bug #244144), and CFLAGS (bug #240786)
+ sed -i \
+ -e '/^CC=/d' \
+ -e "s:^CFLAGS=-Wall -O2 :CFLAGS=-O2 ${CFLAGS} :" \
+ -e '/^LDFLAGS=/d' \
+ -e '/^ripmime\/libripmime/,+7d' \
+ -e '/^\.c\.o:/,+3d' \
+ -e '$ap3scan: LDLIBS:=-lripmime -lpcre -lssl -lcrypto\np3scan: $(OBJECTS)' \
+ Makefile || die
+ # Be sure the system copy is used
+ rm -rf ripmime/
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install () {
+ newinitd ${FILESDIR}/${PN}.init ${PN}
+
+ dosbin ${PN} || die
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins ${PN}.conf ${PN}-*.mail
+ doins ${PN}-*.mail
+
+ keepdir /var/run/${PN}
+
+ keepdir /var/spool/${PN}
+ keepdir /var/spool/${PN}/children
+ keepdir /var/spool/${PN}/notify
+
+ fowners mail:mail /var/run/${PN}
+ fperms 700 /var/run/${PN}
+
+ fowners mail:mail /var/spool/${PN}
+ fperms 700 /var/spool/${PN}
+
+ fowners mail:mail /var/spool/${PN}/children
+ fperms 700 /var/spool/${PN}/children
+
+ fowners mail:mail /var/spool/${PN}/notify
+ fperms 700 /var/spool/${PN}/notify
+
+ doman p3scan.8.gz p3scan_readme.8.gz
+
+ dodoc AUTHORS CHANGELOG CONTRIBUTERS LICENSE NEWS README \
+ README-rpm TODO.list p3scan.sh spamfaq.*
+}
+
+pkg_postinst() {
+ enewuser mail 8 /bin/true /var/spool/mail mail
+
+ if [ ! -L /etc/${PN}/${PN}.mail ]; then
+ ln -sf /etc/${PN}/${PN}-en.mail /etc/${PN}/${PN}.mail
+ fi
+
+ echo
+ elog "Default infected notification template language is set to english, change the"
+ elog "symbolic link /etc/${PN}/${PN}.mail if you want it in another language."
+ elog
+ elog "To start ${PN}, you can use /etc/init.d/${PN} start"
+ elog
+ elog "You need port-redirecting, a rule like:"
+ elog " iptables -t nat -A PREROUTING -p tcp -i eth0 --dport pop3 -j REDIRECT --to 8110"
+ elog "to forward pop3 connections incoming from eth0 interface."
+ elog
+ elog "You will need to configure at least following in /etc/${PN}/${PN}.conf:"
+ elog "scannertype, scanner, virusregexp"
+ elog
+ elog "An example scanner script has been installed to:"
+ elog "/usr/share/doc/${PF}/"
+ echo
+}