summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-31 19:12:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-31 19:12:21 +0000
commita474ce3250cc57e26e1a4a9d3cadc5b4e282f36c (patch)
tree8dc5835ded815df9d4bfe26b9b5d55914cf0b71d /mail-client
parentFix deps. Per bug #257125 (diff)
downloadgentoo-2-a474ce3250cc57e26e1a4a9d3cadc5b4e282f36c.tar.gz
gentoo-2-a474ce3250cc57e26e1a4a9d3cadc5b4e282f36c.tar.bz2
gentoo-2-a474ce3250cc57e26e1a4a9d3cadc5b4e282f36c.zip
Bump to 2.3.28. Use GIO, bug fixes.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/balsa/ChangeLog7
-rw-r--r--mail-client/balsa/balsa-2.3.28.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/mail-client/balsa/ChangeLog b/mail-client/balsa/ChangeLog
index e766793a884a..c2195a6162b9 100644
--- a/mail-client/balsa/ChangeLog
+++ b/mail-client/balsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/balsa
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.75 2009/01/10 16:29:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.76 2009/01/31 19:12:21 eva Exp $
+
+*balsa-2.3.28 (31 Jan 2009)
+
+ 31 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org> +balsa-2.3.28.ebuild:
+ Bump to 2.3.28. Use GIO, bug fixes.
10 Jan 2009; Markus Meier <maekke@gentoo.org> balsa-2.3.26.ebuild:
amd64/x86 stable, bug #254035
diff --git a/mail-client/balsa/balsa-2.3.28.ebuild b/mail-client/balsa/balsa-2.3.28.ebuild
new file mode 100644
index 000000000000..33b9963dea1e
--- /dev/null
+++ b/mail-client/balsa/balsa-2.3.28.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-2.3.28.ebuild,v 1.1 2009/01/31 19:12:21 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="Email client for GNOME"
+HOMEPAGE="http://balsa.gnome.org"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+# Doesn't currently build with -gnome
+IUSE="crypt doc gtkhtml gtkspell kerberos ldap libnotify rubrica sqlite ssl xface"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.10
+ =dev-libs/gmime-2.2*
+ >=net-libs/libesmtp-1.0.3
+ >=gnome-base/orbit-2
+ >=gnome-base/libbonobo-2.0
+ x11-themes/hicolor-icon-theme
+ net-mail/mailbase
+ crypt? ( >=app-crypt/gpgme-1.0 )
+ >=gnome-base/libgnome-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/gconf-2.0
+ >=gnome-base/gnome-keyring-2.20
+ >=x11-libs/gtksourceview-2
+ gtkhtml? ( >=gnome-extra/gtkhtml-3.14 )
+ sqlite? ( >=dev-db/sqlite-2.8 )
+ libnotify? ( x11-libs/libnotify )
+ gtkspell? ( =app-text/gtkspell-2* )
+ !gtkspell? ( virtual/aspell-dict )
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ rubrica? ( dev-libs/libxml2 )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.5.1 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=app-text/scrollkeeper-0.1.4
+ app-text/gnome-doc-utils
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO docs/*"
+
+pkg_setup() {
+ # threads are currently broken with gpgme
+ G2CONF="${G2CONF} --disable-threads"
+
+ if use crypt ; then
+ G2CONF="${G2CONF} --with-gpgme=gpgme-config"
+ else
+ G2CONF="${G2CONF} --without-gpgme"
+ fi
+
+# if use gnome ; then
+ G2CONF="${G2CONF} --with-gtksourceview"
+# else
+# G2CONF="${G2CONF} --without-gtksourceview"
+# fi
+
+ if use gtkhtml ; then
+ G2CONF="${G2CONF} --with-gtkhtml=3"
+ else
+ G2CONF="${G2CONF} --without-gtkhtml"
+ fi
+
+ G2CONF="${G2CONF}
+ --disable-pcre
+ --enable-gregex
+ --enable-threads
+ $(use_with gtkspell)
+ $(use_with kerberos gss)
+ $(use_with ldap)
+ $(use_with libnotify)
+ $(use_with rubrica)
+ $(use_with sqlite)
+ $(use_with ssl)
+ $(use_with xface compface)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Remove disable deprecated statement
+ sed -i -e '/DISABLE_DEPRECATED/d' \
+ libinit_balsa/Makefile.am libinit_balsa/Makefile.in \
+ libbalsa/Makefile.am libbalsa/Makefile.in \
+ src/Makefile.am src/Makefile.in || die "sed failed"
+}