summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-04-12 06:03:28 +0000
committerHans de Graaff <graaff@gentoo.org>2008-04-12 06:03:28 +0000
commit9725a182782ab0723789a858587556588b6e516f (patch)
tree6c9fd5ad30f70d5b2a94aaea927cc6048bb94e44 /mail-client
parentwhitespace (diff)
downloadgentoo-2-9725a182782ab0723789a858587556588b6e516f.tar.gz
gentoo-2-9725a182782ab0723789a858587556588b6e516f.tar.bz2
gentoo-2-9725a182782ab0723789a858587556588b6e516f.zip
Add patch to fix 215154
(Portage version: 2.1.4.4)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mail-notification/ChangeLog11
-rw-r--r--mail-client/mail-notification/files/mail-notification-5.2-evo-crash-fix.patch11
-rw-r--r--mail-client/mail-notification/mail-notification-5.2-r1.ebuild92
3 files changed, 113 insertions, 1 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index 1aa1d4dfedfa..b440222c605c 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for mail-client/mail-notification
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.66 2008/04/10 05:24:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.67 2008/04/12 06:03:27 graaff Exp $
+
+*mail-notification-5.2-r1 (12 Apr 2008)
+
+ 12 Apr 2008; Hans de Graaff <graaff@gentoo.org>
+ +files/mail-notification-5.2-evo-crash-fix.patch,
+ +mail-notification-5.2-r1.ebuild:
+ Add fix for evolution crash, thanks for Pacho Ramos in bug 215154 for locating
+ the patch. Also remove the restriction on tests, as the new build system has
+ no tests at all.
10 Apr 2008; Hans de Graaff <graaff@gentoo.org>
-mail-notification-4.1-r1.ebuild, mail-notification-5.0.ebuild,
diff --git a/mail-client/mail-notification/files/mail-notification-5.2-evo-crash-fix.patch b/mail-client/mail-notification/files/mail-notification-5.2-evo-crash-fix.patch
new file mode 100644
index 000000000000..86bae2a602b4
--- /dev/null
+++ b/mail-client/mail-notification/files/mail-notification-5.2-evo-crash-fix.patch
@@ -0,0 +1,11 @@
+--- build/src/mn-evolution-server.c.orig 2008-03-20 16:53:57.000000000 +0100
++++ build/src/mn-evolution-server.c 2008-04-11 16:14:44.000000000 +0200
+@@ -556,7 +556,7 @@
+ G_TYPE_STRING, camel_message_info_from(info),
+ /* char *subject */
+ G_TYPE_STRING, camel_message_info_subject(info),
+- 0);
++ (GType) 0);
+ }}
+ #line 562 "mn-evolution-server.c"
+ #undef __GOB_FUNCTION__
diff --git a/mail-client/mail-notification/mail-notification-5.2-r1.ebuild b/mail-client/mail-notification/mail-notification-5.2-r1.ebuild
new file mode 100644
index 000000000000..a940e23f213c
--- /dev/null
+++ b/mail-client/mail-notification/mail-notification-5.2-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.2-r1.ebuild,v 1.1 2008/04/12 06:03:27 graaff Exp $
+
+inherit gnome2 multilib flag-o-matic toolchain-funcs
+
+DESCRIPTION="A GNOME trayicon which checks for email, with support for many online and offline mailbox formats."
+HOMEPAGE="http://www.nongnu.org/mailnotify/"
+SRC_URI="http://savannah.nongnu.org/download/mailnotify/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="evo gmail imap ipv6 maildir mbox mh mozilla pop sasl ssl sylpheed yahoo"
+
+# gmime is actually optional, but it's used by so much of the package
+# it's pointless making it optional. gnome-keyring is required for
+# several specific access methods, and thus linked to those USE flags
+# instead of adding a keyring USE flag.
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/glib-2.14
+ >=gnome-base/gconf-2.4.0
+ >=gnome-base/gnome-panel-2.6
+ >=gnome-base/eel-2.6
+ >=gnome-base/gconf-2.6
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/libglade-2.0
+ dev-libs/dbus-glib
+ >=dev-libs/gmime-2.2.7
+ >=x11-libs/libnotify-0.4.1
+ pop? ( gnome-base/gnome-keyring )
+ imap? ( gnome-base/gnome-keyring )
+ gmail? ( gnome-base/gnome-keyring )
+ yahoo? ( gnome-base/gnome-keyring net-mail/fetchyahoo )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ evo? ( >=mail-client/evolution-2.12 )
+ sylpheed? ( virtual/sylpheed )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+# this now uses JB (the Jean-Yves Lefort's Build System) as a build system
+# instead of autotools, this is a little helper function that basically does
+# the same thing as use_enable
+use_var() {
+ echo -n "${2:-$1}="
+ use "${1}" && echo "yes" || echo "no"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-dont-update-cache.patch"
+
+ # Fix crash in evolution, bug #215154
+ use evo && epatch "${FILESDIR}"/${P}-evo-crash-fix.patch
+}
+
+src_compile() {
+ ./jb configure destdir="${D}" prefix="/usr" libdir=/usr/$(get_libdir) \
+ sysconfdir="/etc" localstatedir="/var" cc="$(tc-getCC)" \
+ cflags="${CFLAGS}" cppflags="${CXXFLAGS}" ldflags="${LDFLAGS}" \
+ scrollkeeper-dir="/var/lib/scrollkeeper" \
+ $(use_var evo evolution) \
+ $(use_var gmail) \
+ $(use_var imap) \
+ $(use_var ipv6) \
+ $(use_var maildir) \
+ $(use_var mbox) \
+ $(use_var mh) \
+ $(use_var mozilla) \
+ $(use_var pop pop3) \
+ $(use_var sasl) \
+ $(use_var ssl) \
+ $(use_var sylpheed) \
+ $(use_var yahoo)
+
+ ./jb build
+}
+
+src_install() {
+ GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1" ./jb install
+
+ dodoc NEWS README AUTHORS TODO TRANSLATING
+
+ rm -rf "${D}/var/lib/scrollkeeper"
+}