summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2005-04-23 10:55:23 +0000
committerTom Martin <slarti@gentoo.org>2005-04-23 10:55:23 +0000
commit8edbd0af5db5b4a19b163096d0cb0eb6720ce534 (patch)
treedf9cba5228d764caa815aa62ad06b7c4a4c4a5fb /mail-client
parentThis is one bad puppy - unresolved symbols all over the place. Builds (diff)
downloadgentoo-2-8edbd0af5db5b4a19b163096d0cb0eb6720ce534.tar.gz
gentoo-2-8edbd0af5db5b4a19b163096d0cb0eb6720ce534.tar.bz2
gentoo-2-8edbd0af5db5b4a19b163096d0cb0eb6720ce534.zip
Version bump, resolves bug 84489. Support for gmail timestamps has been added, via a new local USE flag.
(Portage version: 2.0.51.19)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mail-notification/ChangeLog8
-rw-r--r--mail-client/mail-notification/Manifest6
-rw-r--r--mail-client/mail-notification/files/digest-mail-notification-1.11
-rw-r--r--mail-client/mail-notification/mail-notification-1.1.ebuild50
4 files changed, 62 insertions, 3 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index d25b7fcc28b2..0fd97fd6dd2f 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/mail-notification
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.17 2005/03/26 00:09:38 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.18 2005/04/23 10:55:23 slarti Exp $
+
+*mail-notification-1.1 (23 Apr 2005)
+
+ 23 Apr 2005; Tom Martin <slarti@gentoo.org> +mail-notification-1.1.ebuild:
+ Version bump, resolves bug 84489. Support for gmail timestamps has been
+ added, via a new local USE flag.
26 Mar 2005; Michael Hanselmann <hansmi@gentoo.org>
mail-notification-1.0.ebuild:
diff --git a/mail-client/mail-notification/Manifest b/mail-client/mail-notification/Manifest
index f184f31e076c..db8748630829 100644
--- a/mail-client/mail-notification/Manifest
+++ b/mail-client/mail-notification/Manifest
@@ -1,6 +1,8 @@
-MD5 5d240c2111a6535d744ec8bbc7cc692c metadata.xml 249
-MD5 6e4596feae05dcffe96e733cbae24c24 mail-notification-1.0.ebuild 1546
MD5 cfa38c9efc9d85c8b59d9fb8df0aa32b ChangeLog 3304
+MD5 8b89982c39c4823ac8b7c73b22af78a1 mail-notification-1.1.ebuild 1608
+MD5 6e4596feae05dcffe96e733cbae24c24 mail-notification-1.0.ebuild 1546
+MD5 5d240c2111a6535d744ec8bbc7cc692c metadata.xml 249
MD5 e77332c825d2c72566117f6f3117182e mail-notification-0.8.1.ebuild 1548
MD5 a1ac4da13eaa2be84f10c4c769682253 files/digest-mail-notification-1.0 73
+MD5 a5717a3f9a4857a66a2884232fd6f42c files/digest-mail-notification-1.1 73
MD5 4f3f62c7c6d7b58791bba1c52b9dcc52 files/digest-mail-notification-0.8.1 75
diff --git a/mail-client/mail-notification/files/digest-mail-notification-1.1 b/mail-client/mail-notification/files/digest-mail-notification-1.1
new file mode 100644
index 000000000000..329ff39ca2ac
--- /dev/null
+++ b/mail-client/mail-notification/files/digest-mail-notification-1.1
@@ -0,0 +1 @@
+MD5 2359fb53128b12cf295bdf8553e5869b mail-notification-1.1.tar.gz 683776
diff --git a/mail-client/mail-notification/mail-notification-1.1.ebuild b/mail-client/mail-notification/mail-notification-1.1.ebuild
new file mode 100644
index 000000000000..f1c08bef96df
--- /dev/null
+++ b/mail-client/mail-notification/mail-notification-1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-1.1.ebuild,v 1.1 2005/04/23 10:55:23 slarti Exp $
+
+inherit gnome2
+
+DESCRIPTION="A GNOME trayicon which checks for mail supporting mbox, MH,
+Maildir, IMAP, Sylpheed, POP3, Gmail. Authenticates via apop, ssl, sasl."
+HOMEPAGE="http://www.nongnu.org/mailnotify/"
+SRC_URI="http://savannah.nongnu.org/download/mailnotify/${P}.tar.gz"
+
+KEYWORDS="~x86 ~amd64 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE="imap ipv6 mime ssl sasl gmail gmailtimestamps"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ >=dev-util/gob-2
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/eel-2
+ >=gnome-base/gconf-2.4
+ >=gnome-base/libgnomeui-2.4
+ >=gnome-base/libglade-2.0
+ >=gnome-base/eel-2.0
+ >=gnome-base/orbit-2.0
+ dev-perl/XML-Parser
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ mime? ( >=dev-libs/gmime-2.1 )
+ gmail? ( >=net-libs/libsoup-2.2
+ gmailtimestamps? ( >=dev-libs/icu-2.6 ))"
+
+G2CONF="${G2CONF} $(use_enable ssl)"
+G2CONF="${G2CONF} $(use_enable sasl)"
+G2CONF="${G2CONF} $(use_enable ipv6)"
+G2CONF="${G2CONF} $(use_enable imap)"
+G2CONF="${G2CONF} $(use_enable mime)"
+
+# Gmail good to go now. --slarti
+G2CONF="${G2CONF} $(use_enable gmail)"
+
+pkg_postinst() {
+ echo
+ ewarn "Due to a bug in bonobo-activation, your GNOME/X11 session must"
+ ewarn "be restarted for mail-notification to work. If you don't do"
+ ewarn "this, this program will crash during the setup phase."
+ ewarn "See http://bugzilla.gnome.org/show_bug.cgi?id=151082"
+ echo
+}