summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-10-08 16:20:13 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-10-08 16:20:13 +0000
commit84d303bdd01e99e3a9c8f1c52c4605d82113bb62 (patch)
tree0321073e90e172929bf3c0e4ea6dda8e1cd85f00 /mail-client/sylpheed
parentStable for HPPA (bug #194606). (diff)
downloadgentoo-2-84d303bdd01e99e3a9c8f1c52c4605d82113bb62.tar.gz
gentoo-2-84d303bdd01e99e3a9c8f1c52c4605d82113bb62.tar.bz2
gentoo-2-84d303bdd01e99e3a9c8f1c52c4605d82113bb62.zip
new upstream release.
(Portage version: 2.1.3.9)
Diffstat (limited to 'mail-client/sylpheed')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/files/digest-sylpheed-2.4.73
-rw-r--r--mail-client/sylpheed/sylpheed-2.4.7.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index ed842350e24e..c9fb20f1619e 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.249 2007/09/17 14:47:16 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.250 2007/10/08 16:20:12 hattya Exp $
+
+*sylpheed-2.4.7 (08 Oct 2007)
+
+ 08 Oct 2007; Akinori Hattori <hattya@gentoo.org> +sylpheed-2.4.7.ebuild:
+ new upstream release.
17 Sep 2007; Akinori Hattori <hattya@gentoo.org>
-files/sylpheed-namespace.diff, -files/sylpheed-procmime.diff,
diff --git a/mail-client/sylpheed/files/digest-sylpheed-2.4.7 b/mail-client/sylpheed/files/digest-sylpheed-2.4.7
new file mode 100644
index 000000000000..53ef73da8527
--- /dev/null
+++ b/mail-client/sylpheed/files/digest-sylpheed-2.4.7
@@ -0,0 +1,3 @@
+MD5 1f82dd04204e334280eecb59fa2c3b1b sylpheed-2.4.7.tar.bz2 2762763
+RMD160 326a75dda16777260ddb08a69e6eca1ad1a61b4e sylpheed-2.4.7.tar.bz2 2762763
+SHA256 76f0ce0a8b7bb35e93102e59e06c17928587525be1ae1762331a959f36b6c844 sylpheed-2.4.7.tar.bz2 2762763
diff --git a/mail-client/sylpheed/sylpheed-2.4.7.ebuild b/mail-client/sylpheed/sylpheed-2.4.7.ebuild
new file mode 100644
index 000000000000..30f45f65de63
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-2.4.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.4.7.ebuild,v 1.1 2007/10/08 16:20:12 hattya Exp $
+
+inherit autotools eutils
+
+IUSE="crypt ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+AT_M4DIR="ac"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.*.diff
+
+ use crypt || cp ac/missing/gpgme.m4 ac
+
+ eautomake
+
+}
+
+src_compile() {
+
+ local htmldir=/usr/share/doc/${PF}/html
+
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable nls) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+ doicon *.png
+ domenu *.desktop
+
+}