summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2014-01-17 13:34:50 +0000
committerAkinori Hattori <hattya@gentoo.org>2014-01-17 13:34:50 +0000
commit2d62932718424afd7e592542280adfdb0cd713d5 (patch)
treec73d5bc84e80532a4b38f93fde85045045075f22 /mail-client/sylpheed
parentVersion bump. Removed old (diff)
downloadgentoo-2-2d62932718424afd7e592542280adfdb0cd713d5.tar.gz
gentoo-2-2d62932718424afd7e592542280adfdb0cd713d5.tar.bz2
gentoo-2-2d62932718424afd7e592542280adfdb0cd713d5.zip
install attachment_tool plugin, fixes bug #497544
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EC917A6D)
Diffstat (limited to 'mail-client/sylpheed')
-rw-r--r--mail-client/sylpheed/ChangeLog9
-rw-r--r--mail-client/sylpheed/sylpheed-3.3.0-r1.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 11952d167416..98d3c9b47b30 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.330 2013/05/23 14:48:46 hattya Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.331 2014/01/17 13:34:50 hattya Exp $
+
+*sylpheed-3.3.0-r1 (17 Jan 2014)
+
+ 17 Jan 2014; Akinori Hattori <hattya@gentoo.org> +sylpheed-3.3.0-r1.ebuild:
+ install attachment_tool plugin, fixes bug #497544
23 May 2013; Akinori Hattori <hattya@gentoo.org> -sylpheed-3.2.0.ebuild:
remove old ebuild
diff --git a/mail-client/sylpheed/sylpheed-3.3.0-r1.ebuild b/mail-client/sylpheed/sylpheed-3.3.0-r1.ebuild
new file mode 100644
index 000000000000..d454a70a5942
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.3.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-3.3.0-r1.ebuild,v 1.1 2014/01/17 13:34:49 hattya Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt ipv6 ldap nls oniguruma pda spell ssl xface"
+
+CDEPEND="x11-libs/gtk+:2
+ nls? ( sys-devel/gettext )
+ crypt? ( app-crypt/gpgme )
+ ldap? ( net-nds/openldap )
+ oniguruma? ( dev-libs/oniguruma )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell:2 )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types
+ net-misc/curl"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ xface? ( media-libs/compface )"
+
+src_configure() {
+ local htmldir=/usr/share/doc/${PF}/html
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable oniguruma) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* NEWS* PLUGIN* README* TODO*
+
+ doicon *.png
+ domenu *.desktop
+
+ cd plugin/attachment_tool
+ docinto plugin/attachment_tool
+ emake DESTDIR="${D}" install-plugin
+ dodoc README
+}