summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2009-02-15 17:04:46 +0000
committerCarsten Lohrke <carlo@gentoo.org>2009-02-15 17:04:46 +0000
commitf7e75879594bb372b825e1fb4de9eedf22a6a6da (patch)
tree333e8a206e73a68171574b790b7adfb4b0359114 /kde-misc
parentAdd cppserv-0.2.5 (diff)
downloadgentoo-2-f7e75879594bb372b825e1fb4de9eedf22a6a6da.tar.gz
gentoo-2-f7e75879594bb372b825e1fb4de9eedf22a6a6da.tar.bz2
gentoo-2-f7e75879594bb372b825e1fb4de9eedf22a6a6da.zip
Version bump. Get rid of invalid aRts dependency. Missing kde.eclass function calls.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tellico/ChangeLog11
-rw-r--r--kde-misc/tellico/files/tellico-1.3.5-test-ldadd.diff11
-rw-r--r--kde-misc/tellico/tellico-1.3.5.ebuild73
3 files changed, 93 insertions, 2 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index 7890609d46e1..e577d59311b2 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-misc/tellico
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.79 2008/12/05 23:01:46 patrick Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.80 2009/02/15 17:04:45 carlo Exp $
+
+*tellico-1.3.5 (15 Feb 2009)
+
+ 15 Feb 2009; Carsten Lohrke <carlo@gentoo.org>
+ +files/tellico-1.3.5-test-ldadd.diff, +tellico-1.3.5.ebuild:
+ Version bump. Get rid of invalid aRts dependency. Missing kde.eclass
+ function calls.
*tellico-1.3.4 (06 Dec 2008)
diff --git a/kde-misc/tellico/files/tellico-1.3.5-test-ldadd.diff b/kde-misc/tellico/files/tellico-1.3.5-test-ldadd.diff
new file mode 100644
index 000000000000..18c3c89b582f
--- /dev/null
+++ b/kde-misc/tellico/files/tellico-1.3.5-test-ldadd.diff
@@ -0,0 +1,11 @@
+--- src/tests/Makefile.am.o 2009-02-15 17:27:42.000000000 +0100
++++ src/tests/Makefile.am 2009-02-15 17:28:02.000000000 +0100
+@@ -16,7 +16,7 @@
+ DISTCLEANFILES = *~ *.Po $(CLEANFILES)
+
+ isbntest_SOURCES = isbntest.cpp
+-isbntest_LDADD = ../isbnvalidator.o $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI)
++isbntest_LDADD = ../isbnvalidator.o ../upcvalidator.o $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI)
+
+ latin1test_SOURCES = latin1test.cpp
+ latin1test_LDADD = $(LIB_QT) $(LIB_KDECORE)
diff --git a/kde-misc/tellico/tellico-1.3.5.ebuild b/kde-misc/tellico/tellico-1.3.5.ebuild
new file mode 100644
index 000000000000..447292631496
--- /dev/null
+++ b/kde-misc/tellico/tellico-1.3.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-1.3.5.ebuild,v 1.1 2009/02/15 17:04:45 carlo Exp $
+
+EAPI="1"
+
+ARTS_REQUIRED="never"
+
+inherit kde sgml-catalog eutils
+
+MY_P=${P/_/}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A collection manager for the KDE environment."
+HOMEPAGE="http://www.periapsis.org/tellico"
+SRC_URI="http://www.periapsis.org/tellico/download/${MY_P}.tar.gz
+ mirror://gentoo/kde-admindir-3.5.5.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="calendar cddb yaz"
+
+DEPEND=">=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.0.19
+ cddb? ( || ( kde-base/libkcddb:3.5 kde-base/kdemultimedia:3.5 ) )
+ calendar? ( || ( ( kde-base/ktnef:3.5 kde-base/libkcal:3.5 ) kde-base/kdepim:3.5 ) )
+ media-libs/taglib
+ yaz? ( dev-libs/yaz )"
+RDEPEND="${DEPEND}"
+need-kde 3.5
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3-releaseflaws.patch"
+ "${FILESDIR}/tellico-1.3.5-test-ldadd.diff"
+ )
+
+src_unpack() {
+ kde_src_unpack
+ rm -f "${S}"/configure
+}
+
+src_compile() {
+ local myconf="$(use_enable cddb libkcddb) $(use_enable calendar libkcal)"
+ rm -f "${S}/configure"
+ kde_src_compile
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ einfo "Installing catalog..."
+ "${ROOT}"/usr/bin/xmlcatalog --noout --add "delegatePublic" \
+ "-//Robby Stephenson/DTD Tellico V9.0//EN" \
+ "file:/"${ROOT}"usr/share/apps/tellico/tellico.dtd" \
+ "${ROOT}"/etc/xml/catalog
+ "${ROOT}"/usr/bin/xmlcatalog --noout --add "delegateSystem" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file:/"${ROOT}"usr/share/apps/tellico/tellico.dtd" \
+ "${ROOT}"/etc/xml/catalog
+ "${ROOT}"/usr/bin/xmlcatalog --noout --add "delegateURI" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file:/"${ROOT}"usr/share/apps/tellico/tellico.dtd" \
+ "${ROOT}"/etc/xml/catalog
+}
+
+pkg_postrm() {
+ kde_pkg_postrm
+
+ "${ROOT}"/usr/bin/xmlcatalog --noout --del \
+ "file:/"${ROOT}"usr/share/apps/tellico/tellico.dtd" \
+ "${ROOT}"/etc/xml/catalog
+}