summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-02-03 10:18:42 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-02-03 10:18:42 +0000
commit159cf91d711e8f44ded287b03e95a27364b118eb (patch)
tree37c0d7d832e12ce51971bec64df782a494782441 /kde-misc/kopete-antispam
parentFixed build issue with newer compiler, bug #251437, thank Diego E. 'Flameeyes... (diff)
downloadgentoo-2-159cf91d711e8f44ded287b03e95a27364b118eb.tar.gz
gentoo-2-159cf91d711e8f44ded287b03e95a27364b118eb.tar.bz2
gentoo-2-159cf91d711e8f44ded287b03e95a27364b118eb.zip
Fix linkage for kopete-antispam
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/kopete-antispam')
-rw-r--r--kde-misc/kopete-antispam/ChangeLog6
-rw-r--r--kde-misc/kopete-antispam/files/kopete-antispam-0.4-fixlink.patch44
-rw-r--r--kde-misc/kopete-antispam/kopete-antispam-0.4.ebuild4
3 files changed, 52 insertions, 2 deletions
diff --git a/kde-misc/kopete-antispam/ChangeLog b/kde-misc/kopete-antispam/ChangeLog
index 12b04cb7a652..96fb3f367bee 100644
--- a/kde-misc/kopete-antispam/ChangeLog
+++ b/kde-misc/kopete-antispam/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-misc/kopete-antispam
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kopete-antispam/ChangeLog,v 1.1 2009/02/01 18:45:34 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kopete-antispam/ChangeLog,v 1.2 2009/02/03 10:18:42 alexxy Exp $
+
+ 03 Feb 2009; Alexey Shvetsov <alexxy@gentoo.org>
+ +files/kopete-antispam-0.4-fixlink.patch, kopete-antispam-0.4.ebuild:
+ Fix linkage
*kopete-antispam-0.4 (01 Feb 2009)
diff --git a/kde-misc/kopete-antispam/files/kopete-antispam-0.4-fixlink.patch b/kde-misc/kopete-antispam/files/kopete-antispam-0.4-fixlink.patch
new file mode 100644
index 000000000000..e92ff398ab4f
--- /dev/null
+++ b/kde-misc/kopete-antispam/files/kopete-antispam-0.4-fixlink.patch
@@ -0,0 +1,44 @@
+--- kopete-antispam-kde4-0.4/CMakeLists.txt.orig 2009-02-03 13:12:45.000000000 +0300
++++ kopete-antispam-kde4-0.4/CMakeLists.txt 2009-02-03 13:13:36.000000000 +0300
+@@ -2,10 +2,14 @@
+
+ find_package( KDE4 REQUIRED )
+ find_package( Automoc4 REQUIRED )
+-
++find_package( Qt4 REQUIRED )
++set(QT_USE_QTGUI 1)
++set(QT_USE_QTCORE 1)
++set(QT_USE_QT3SUPPORT 1)
++include(${QT_USE_FILE})
+ add_definitions(${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
+
+-include_directories( ${KDE4_INCLUDES} ${CMAKE_CURRENT_BINARY_DIR} )
++include_directories( ${KDE4_INCLUDES} ${CMAKE_CURRENT_BINARY_DIR} )
+ link_directories( ${KDE4_LIB_DIR} ${CMAKE_CURRENT_BINARY_DIR} )
+
+ # libkopete_antispam
+@@ -15,7 +19,7 @@
+ kde4_add_kcfg_files( KOPETEANTISPAM_SRCS kopeteantispamconfig.kcfgc )
+
+ kde4_add_plugin( kopete_antispam ${KOPETEANTISPAM_SRCS} )
+-target_link_libraries( kopete_antispam kopete kdeui )
++target_link_libraries( kopete_antispam kopete kdecore kdeui ${QT_LIBRARIES} )
+
+ # libkcm_kopete_antispam
+
+@@ -25,11 +29,12 @@
+ kde4_add_ui_files( KCMKOPETEANTISPAM_SRCS kopeteantispampreferencesuibase.ui )
+
+ kde4_add_plugin( kcm_kopete_antispam ${KCMKOPETEANTISPAM_SRCS} )
+-target_link_libraries( kcm_kopete_antispam kopete kdeui )
++target_link_libraries( kcm_kopete_antispam kopete kdecore kdeui ${QT_LIBRARIES} )
+
+ # installation
+
+ install( FILES kopeteantispamconfig.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
+ install( FILES kopete_antispam.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+ install( FILES kopete_antispam_config.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kconfiguredialog )
+-install( TARGETS kopete_antispam kcm_kopete_antispam DESTINATION ${PLUGIN_INSTALL_DIR} )
+\ В конце файла нет новой строки
++install( TARGETS kopete_antispam kcm_kopete_antispam DESTINATION ${PLUGIN_INSTALL_DIR} )
++
diff --git a/kde-misc/kopete-antispam/kopete-antispam-0.4.ebuild b/kde-misc/kopete-antispam/kopete-antispam-0.4.ebuild
index 0da6e8ba4dfb..8e90831bf89c 100644
--- a/kde-misc/kopete-antispam/kopete-antispam-0.4.ebuild
+++ b/kde-misc/kopete-antispam/kopete-antispam-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kopete-antispam/kopete-antispam-0.4.ebuild,v 1.1 2009/02/01 18:45:34 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kopete-antispam/kopete-antispam-0.4.ebuild,v 1.2 2009/02/03 10:18:42 alexxy Exp $
EAPI="2"
KDE_MINIMAL="4.1"
@@ -23,6 +23,8 @@ DEPEND=">=kde-base/kopete-${KDE_MINIMAL}"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/${P}-fixlink.patch" )
+
pkg_postinst() {
elog "You can now enable and set up the Antispam plugin in Kopete."
elog "It can be reached in the Kopete Plugin dialog."