summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-10-06 20:45:45 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-10-06 20:45:45 +0000
commitfa32525aebb728864abdcde1740fc364b40d2c4d (patch)
tree6a316e06fcd9c714b68a3bf16878b62a17de7a65 /kde-misc/gx-mail-notify
parentVersion bump (diff)
downloadgentoo-2-fa32525aebb728864abdcde1740fc364b40d2c4d.tar.gz
gentoo-2-fa32525aebb728864abdcde1740fc364b40d2c4d.tar.bz2
gentoo-2-fa32525aebb728864abdcde1740fc364b40d2c4d.zip
Version bump, fixes bug 326397, bug 323053 (gcc 4.5 compilation) and bug 338565 (qt 4.7 compilation)
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/gx-mail-notify')
-rw-r--r--kde-misc/gx-mail-notify/ChangeLog11
-rw-r--r--kde-misc/gx-mail-notify/files/gx-mail-notify-qt-4.7.patch10
-rw-r--r--kde-misc/gx-mail-notify/gx-mail-notify-0.4.2.ebuild5
-rw-r--r--kde-misc/gx-mail-notify/gx-mail-notify-0.4.4.ebuild28
4 files changed, 50 insertions, 4 deletions
diff --git a/kde-misc/gx-mail-notify/ChangeLog b/kde-misc/gx-mail-notify/ChangeLog
index d2a64bfb669a..ba7fd50c8a7f 100644
--- a/kde-misc/gx-mail-notify/ChangeLog
+++ b/kde-misc/gx-mail-notify/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-misc/gx-mail-notify
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/gx-mail-notify/ChangeLog,v 1.1 2009/11/03 13:03:41 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/gx-mail-notify/ChangeLog,v 1.2 2010/10/06 20:45:44 tampakrap Exp $
+
+*gx-mail-notify-0.4.4 (06 Oct 2010)
+
+ 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +gx-mail-notify-0.4.4.ebuild, +files/gx-mail-notify-qt-4.7.patch:
+ Version bump, fixes bug 326397, bug 323053 (gcc 4.5 compilation) and bug
+ 338565 (qt 4.7 compilation)
*gx-mail-notify-0.4.2 (03 Nov 2009)
diff --git a/kde-misc/gx-mail-notify/files/gx-mail-notify-qt-4.7.patch b/kde-misc/gx-mail-notify/files/gx-mail-notify-qt-4.7.patch
new file mode 100644
index 000000000000..1619f3b08f03
--- /dev/null
+++ b/kde-misc/gx-mail-notify/files/gx-mail-notify-qt-4.7.patch
@@ -0,0 +1,10 @@
+--- a/mail_checker.cpp 2010-10-02 17:02:29.833334239 +0200
++++ b/mail_checker.cpp 2010-05-05 22:54:26.000000000 +0200
+@@ -19,7 +19,7 @@
+ #include <KDebug>
+
+ MailChecker::MailChecker(Account * account) : QObject(),
+- actual_action(CLOSE_CONNECTION), certificate_details_dialog(0), time_to_check(0), check_messages(-1), check_error(false)
++ actual_action(CLOSE_CONNECTION), certificate_details_dialog(0), time_to_check(0), check_messages(-1)
+ {
+ this->account = account;
diff --git a/kde-misc/gx-mail-notify/gx-mail-notify-0.4.2.ebuild b/kde-misc/gx-mail-notify/gx-mail-notify-0.4.2.ebuild
index 57b57f4fb758..a94cb2c46232 100644
--- a/kde-misc/gx-mail-notify/gx-mail-notify-0.4.2.ebuild
+++ b/kde-misc/gx-mail-notify/gx-mail-notify-0.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/gx-mail-notify/gx-mail-notify-0.4.2.ebuild,v 1.1 2009/11/03 13:03:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/gx-mail-notify/gx-mail-notify-0.4.2.ebuild,v 1.2 2010/10/06 20:45:45 tampakrap Exp $
EAPI=2
inherit kde4-base
@@ -18,6 +18,7 @@ IUSE="debug"
DEPEND=">=kde-base/kdelibs-${KDE_MINIMAL}[opengl]
>=kde-base/plasma-workspace-${KDE_MINIMAL}"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
diff --git a/kde-misc/gx-mail-notify/gx-mail-notify-0.4.4.ebuild b/kde-misc/gx-mail-notify/gx-mail-notify-0.4.4.ebuild
new file mode 100644
index 000000000000..92ef5114f4c7
--- /dev/null
+++ b/kde-misc/gx-mail-notify/gx-mail-notify-0.4.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/gx-mail-notify/gx-mail-notify-0.4.4.ebuild,v 1.1 2010/10/06 20:45:44 tampakrap Exp $
+
+EAPI=3
+
+OPENGL_REQUIRED=always
+inherit kde4-base
+
+MY_P=gx_mail_notify-${PV}
+
+DESCRIPTION="A plasmoid for checking unread mail"
+HOMEPAGE="http://www.kde-look.org/content/show.php/GX+Mail+Notify?content=99617"
+SRC_URI="http://www.kde-look.org/CONTENT/content-files/99617-${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="$(add_kdebase_dep plasma-workspace)"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-qt-4.7.patch" )
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( README )