summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-14 22:23:59 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-14 22:23:59 +0000
commitf48138536b83a6ccb05cd1ad3ad046fd021421f1 (patch)
treef6f3a7b3ff4bb240c64bd5773ff8dd6c47b7252b /kde-base
parentRemove unused patch. (diff)
downloadgentoo-2-f48138536b83a6ccb05cd1ad3ad046fd021421f1.tar.gz
gentoo-2-f48138536b83a6ccb05cd1ad3ad046fd021421f1.tar.bz2
gentoo-2-f48138536b83a6ccb05cd1ad3ad046fd021421f1.zip
Remove unused patches.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/plasma-workspace/ChangeLog8
-rw-r--r--kde-base/plasma-workspace/files/plasma-workspace-4.10.4-crypt.patch74
-rw-r--r--kde-base/plasma-workspace/files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch30
-rw-r--r--kde-base/plasma-workspace/files/plasma-workspace-4.10.5-leak.patch59
4 files changed, 7 insertions, 164 deletions
diff --git a/kde-base/plasma-workspace/ChangeLog b/kde-base/plasma-workspace/ChangeLog
index 1a7a07637ece..f2f64ba9bc8d 100644
--- a/kde-base/plasma-workspace/ChangeLog
+++ b/kde-base/plasma-workspace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/plasma-workspace
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.254 2013/12/12 03:37:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.255 2013/12/14 22:23:58 johu Exp $
+
+ 14 Dec 2013; Johannes Huber <johu@gentoo.org>
+ -files/plasma-workspace-4.10.4-crypt.patch,
+ -files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch,
+ -files/plasma-workspace-4.10.5-leak.patch:
+ Remove unused patches.
12 Dec 2013; Agostino Sarubbo <ago@gentoo.org>
-plasma-workspace-4.10.5-r2.ebuild:
diff --git a/kde-base/plasma-workspace/files/plasma-workspace-4.10.4-crypt.patch b/kde-base/plasma-workspace/files/plasma-workspace-4.10.4-crypt.patch
deleted file mode 100644
index 6d36a07aae3d..000000000000
--- a/kde-base/plasma-workspace/files/plasma-workspace-4.10.4-crypt.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 45b7f137fbc0b942fd2c9b4e8d8c1f0293e64ba7 Mon Sep 17 00:00:00 2001
-From: Michael Pyne <mpyne@kde.org>
-Date: Sat, 29 Jun 2013 16:13:20 -0400
-Subject: [PATCH] kdm, kcheckpass: Check for NULL return from crypt(3) and
- friends.
-
-Potential issue noted and fixed by Mancha <mancha1@hush.com>.
-
-Patch reviewed by myself and ossi. Backported to 4.10 by myself.
-
-REVIEW:111261
-FIXED-IN:4.10.5
----
- kcheckpass/checkpass_etcpasswd.c | 3 ++-
- kcheckpass/checkpass_osfc2passwd.c | 3 ++-
- kcheckpass/checkpass_shadow.c | 2 +-
- kdm/backend/client.c | 7 +++++--
- 4 files changed, 10 insertions(+), 5 deletions(-)
-
-diff --git a/kcheckpass/checkpass_etcpasswd.c b/kcheckpass/checkpass_etcpasswd.c
-index 1dbe06f..e261b7c 100644
---- a/kcheckpass/checkpass_etcpasswd.c
-+++ b/kcheckpass/checkpass_etcpasswd.c
-@@ -35,6 +35,7 @@ AuthReturn Authenticate(const char *method,
- {
- struct passwd *pw;
- char *passwd;
-+ char *crpt_passwd;
-
- if (strcmp(method, "classic"))
- return AuthError;
-@@ -49,7 +50,7 @@ AuthReturn Authenticate(const char *method,
- if (!(passwd = conv(ConvGetHidden, 0)))
- return AuthAbort;
-
-- if (!strcmp(pw->pw_passwd, crypt(passwd, pw->pw_passwd))) {
-+ if ((crpt_passwd = crypt(passwd, pw->pw_passwd)) && !strcmp(pw->pw_passwd, crpt_passwd)) {
- dispose(passwd);
- return AuthOk; /* Success */
- }
-diff --git a/kcheckpass/checkpass_osfc2passwd.c b/kcheckpass/checkpass_osfc2passwd.c
-index 9a074f9..d181233 100644
---- a/kcheckpass/checkpass_osfc2passwd.c
-+++ b/kcheckpass/checkpass_osfc2passwd.c
-@@ -38,6 +38,7 @@ AuthReturn Authenticate(const char *method,
- const char *login, char *(*conv) (ConvRequest, const char *))
- {
- char *passwd;
-+ char *crpt_passwd;
- char c2passwd[256];
-
- if (strcmp(method, "classic"))
-@@ -52,7 +53,7 @@ AuthReturn Authenticate(const char *method,
- if (!(passwd = conv(ConvGetHidden, 0)))
- return AuthAbort;
-
-- if (!strcmp(c2passwd, osf1c2crypt(passwd, c2passwd))) {
-+ if ((crpt_passwd = osf1c2crypt(passwd, c2passwd)) && !strcmp(c2passwd, crpt_passwd)) {
- dispose(passwd);
- return AuthOk; /* Success */
- }
-diff --git a/kcheckpass/checkpass_shadow.c b/kcheckpass/checkpass_shadow.c
-index ec3a4e0..c0f6913 100644
---- a/kcheckpass/checkpass_shadow.c
-+++ b/kcheckpass/checkpass_shadow.c
-@@ -69,7 +69,7 @@ AuthReturn Authenticate(const char *method,
- crpt_passwd = crypt(typed_in_password, password);
- #endif
-
-- if (!strcmp(password, crpt_passwd )) {
-+ if (crpt_passwd && !strcmp(password, crpt_passwd )) {
- dispose(typed_in_password);
- return AuthOk; /* Success */
- }
diff --git a/kde-base/plasma-workspace/files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch b/kde-base/plasma-workspace/files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch
deleted file mode 100644
index 500fe1781bb6..000000000000
--- a/kde-base/plasma-workspace/files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-commit 72b9956766b26164628ccc979952fd1ae5bc5e41
-Author: Kai Uwe Broulik <kde@privat.broulik.de>
-Date: Tue Jun 4 17:47:17 2013 +0200
-
- Also set minimum size when it *is* constrained
-
- BUG: 309447
- FIXED-IN: 4.11.0
-
-* 2013-06-04: Backport to 4.10.4
-
-diff --git a/plasma/generic/applets/batterymonitor/contents/ui/CompactRepresentation.qml b/plasma/generic/applets/batterymonitor/contents/ui/CompactRepresentation.qml
-index f8691a1..e9dc772 100644
---- a/plasma/generic/applets/batterymonitor/contents/ui/batterymonitor.qml 2013-05-28 20:38:22.000000000 +0200
-+++ b/plasma/generic/applets/batterymonitor/contents/ui/batterymonitor.qml 2013-06-04 21:15:26.234102844 +0200
-@@ -70,8 +70,12 @@
-
- Component.onCompleted: {
- if (!isConstrained()) {
-- minimumWidth = 32;
-- minimumHeight = 32;
-+ minimumWidth = theme.iconSizes.dialog;
-+ minimumHeight = minimumHeight * view.count;
-+ } else {
-+ // NOTE: Keep in sync with systray
-+ minimumHeight = 24;
-+ minimumWidth = 24;
- }
- plasmoid.addEventListener('ConfigChanged', configChanged);
- }
diff --git a/kde-base/plasma-workspace/files/plasma-workspace-4.10.5-leak.patch b/kde-base/plasma-workspace/files/plasma-workspace-4.10.5-leak.patch
deleted file mode 100644
index d4e2c5d6033d..000000000000
--- a/kde-base/plasma-workspace/files/plasma-workspace-4.10.5-leak.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From ec8e405ca447ba5bc5a9f6a2a12e2fa90412a0d4 Mon Sep 17 00:00:00 2001
-From: Andreas Hartmetz <ahartmetz@gmail.com>
-Date: Tue, 2 Jul 2013 18:35:35 +0200
-Subject: [PATCH] Fix pixmap leak when the tray icon changes (e.g. when it's
- animated).
-
-This could easily leak 4KB/second of X pixmap memory.
-All the actual difference comes from the QPixmap::ExplicitlyShared
-argument, the rest is making some wonky-looking but working code look
-less wonky.
-
-BUG: 314919
----
- .../systemtray/protocols/fdo/x11embedcontainer.cpp | 19 ++++++++++---------
- 1 file changed, 10 insertions(+), 9 deletions(-)
-
-diff --git a/plasma/generic/applets/systemtray/protocols/fdo/x11embedcontainer.cpp b/plasma/generic/applets/systemtray/protocols/fdo/x11embedcontainer.cpp
-index 1826512..a5bc826 100644
---- a/plasma/generic/applets/systemtray/protocols/fdo/x11embedcontainer.cpp
-+++ b/plasma/generic/applets/systemtray/protocols/fdo/x11embedcontainer.cpp
-@@ -194,8 +194,7 @@ void X11EmbedContainer::paintEvent(QPaintEvent *event)
-
- // Taking a detour via a QPixmap is unfortunately the only way we can get
- // the window contents into Qt's backing store.
-- QPixmap pixmap(size());
-- pixmap = toX11Pixmap(pixmap);
-+ QPixmap pixmap = toX11Pixmap(QPixmap(size()));
- pixmap.fill(Qt::transparent);
- XRenderComposite(x11Info().display(), PictOpSrc, d->picture, None, pixmap.x11PictureHandle(),
- 0, 0, 0, 0, 0, 0, width(), height());
-@@ -232,16 +231,18 @@ void X11EmbedContainer::setBackgroundPixmap(QPixmap background)
- // NOTE: The alpha-channel is not preserved if it exists, but for X pixmaps it generally should not be needed anyway.
- QPixmap X11EmbedContainer::toX11Pixmap(const QPixmap& pix)
- {
-- if(pix.handle() != 0) // X11 pixmap
-+ if (pix.handle() != 0) // X11 pixmap
- return pix;
-+ QPixmap ret;
- Pixmap xpix = XCreatePixmap(pix.x11Info().display(), RootWindow(pix.x11Info().display(), pix.x11Info().screen()),
- pix.width(), pix.height(), QX11Info::appDepth());
-- QPixmap wrk = QPixmap::fromX11Pixmap(xpix);
-- QPainter paint(&wrk);
-- paint.drawPixmap(0, 0, pix);
-- paint.end();
-- QPixmap ret = wrk.copy();
-- wrk = QPixmap(); // reset, so that xpix can be freed (QPixmap does not own it)
-+ {
-+ QPixmap wrk = QPixmap::fromX11Pixmap(xpix, QPixmap::ExplicitlyShared);
-+ QPainter paint(&wrk);
-+ paint.drawPixmap(0, 0, pix);
-+ paint.end();
-+ ret = wrk.copy();
-+ } // free resources so that xpix can be freed (QPixmap does not own it)
- XFreePixmap(pix.x11Info().display(), xpix);
- return ret;
- }
---
-1.8.2.1
-