summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-01-25 17:31:43 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-01-25 17:31:43 +0000
commit219d7d80f65c8781f0ba68d4884d6caa685ce99f (patch)
tree55b4642148c3f35bfbc739fee7fcb715836a4a5b /kde-base
parentVersion bump KDE 4.3.5 (diff)
downloadgentoo-2-219d7d80f65c8781f0ba68d4884d6caa685ce99f.tar.gz
gentoo-2-219d7d80f65c8781f0ba68d4884d6caa685ce99f.tar.bz2
gentoo-2-219d7d80f65c8781f0ba68d4884d6caa685ce99f.zip
Version bump KDE 4.3.5
(Portage version: 2.2_rc61/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/phonon-kde/ChangeLog8
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.3.5.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 0b35f47eb2b0..ac63af6619ed 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.43 2010/01/23 17:08:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.44 2010/01/25 17:31:43 scarabeus Exp $
+
+*phonon-kde-4.3.5 (25 Jan 2010)
+
+ 25 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +phonon-kde-4.3.5.ebuild:
+ Version bump
23 Jan 2010; Raúl Porcel <armin76@gentoo.org> phonon-kde-4.3.4.ebuild:
Add ~arm
diff --git a/kde-base/phonon-kde/phonon-kde-4.3.5.ebuild b/kde-base/phonon-kde/phonon-kde-4.3.5.ebuild
new file mode 100644
index 000000000000..e37b819a1475
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.3.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.3.5.ebuild,v 1.1 2010/01/25 17:31:43 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="alsa debug pulseaudio +xine"
+
+DEPEND="
+ media-sound/phonon[xine?]
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}"
+
+add_blocker phonon-xine
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.4-optional-alsa.patch
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ # Don't build tests - they require OpenGL
+ sed -e 's/add_subdirectory(tests)//' \
+ -i phonon/CMakeLists.txt || die "Failed to disable tests"
+
+ # Disable automagic
+ sed -e 's/find_package(Xine)/macro_optional_find_package(Xine)/' \
+ -i phonon/kcm/xine/CMakeLists.txt || die "Failed to make xine optional"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ $(cmake-utils_use_with xine)
+ )
+
+ kde4-meta_src_configure
+}