summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-01-18 16:10:08 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-01-18 16:10:08 +0000
commit0dfbec44d3d74c03cb305b09ccb21e8cae418345 (patch)
treee6b17a15b06e2bbff9fbbf89417204ff19f4ae31 /kde-base
parentAdd comment (Manifest recommit) (diff)
downloadgentoo-2-0dfbec44d3d74c03cb305b09ccb21e8cae418345.tar.gz
gentoo-2-0dfbec44d3d74c03cb305b09ccb21e8cae418345.tar.bz2
gentoo-2-0dfbec44d3d74c03cb305b09ccb21e8cae418345.zip
Disable python scripting support (#40543).
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kig/kig-3.4.0_beta1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/kde-base/kig/kig-3.4.0_beta1.ebuild b/kde-base/kig/kig-3.4.0_beta1.ebuild
index dc60af8ae1e1..0cb2186a7c27 100644
--- a/kde-base/kig/kig-3.4.0_beta1.ebuild
+++ b/kde-base/kig/kig-3.4.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-3.4.0_beta1.ebuild,v 1.1 2005/01/15 02:24:33 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-3.4.0_beta1.ebuild,v 1.2 2005/01/18 16:10:08 greg_g Exp $
KMNAME=kdeedu
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
@@ -11,3 +11,10 @@ KEYWORDS="~x86"
IUSE=""
DEPEND=""
+src_compile() {
+ # the scripting support in kig is strongly dependent on the version
+ # of dev-libs/boost and of python installed, and often fails to compile.
+ myconf="${myconf} --disable-kig-python-scripting"
+
+ kde_src_compile
+}