summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
commitb2b19c584143aa3164437f01988775b3baced7a1 (patch)
treed682b95b673d238fe82f54a47550663464f4e5cd /kde-base/thumbnailers/thumbnailers-4.6.4.ebuild
parentSort test dep. Remove useless dies. (diff)
downloadgentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.tar.gz
gentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.tar.bz2
gentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.zip
Version bump
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/thumbnailers/thumbnailers-4.6.4.ebuild')
-rw-r--r--kde-base/thumbnailers/thumbnailers-4.6.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/thumbnailers/thumbnailers-4.6.4.ebuild b/kde-base/thumbnailers/thumbnailers-4.6.4.ebuild
new file mode 100644
index 000000000000..29b05e0cae62
--- /dev/null
+++ b/kde-base/thumbnailers/thumbnailers-4.6.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/thumbnailers/thumbnailers-4.6.4.ebuild,v 1.1 2011/06/10 17:59:49 dilfridge Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdegraphics"
+ kde_eclass="kde4-meta"
+fi
+
+inherit ${kde_eclass}
+
+DESCRIPTION="KDE 4 thumbnail generators for PDF/PS files"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+KMEXTRACTONLY="
+ libs/mobipocket
+"
+
+DEPEND="
+ $(add_kdebase_dep libkdcraw)
+ $(add_kdebase_dep libkexiv2)
+"
+RDEPEND="${DEPEND}"
+
+add_blocker kdegraphics-strigi-analyzer '<4.2.91'
+
+if [[ ${PV} != *9999 ]]; then
+src_install() {
+ kde4-meta_src_install
+
+ # why, oh why?!
+ rm "${ED}/usr/share/apps/cmake/modules/FindKSane.cmake" || die
+}
+fi