summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-29 18:35:19 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-29 18:35:19 +0000
commite022af9e09a506be3fa71a44a9dacb94554ae3b0 (patch)
tree927f368d76846ba1fc8372e4a16b73202107d984 /kde-base/superkaramba
parentfixing testing (diff)
downloadgentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.tar.gz
gentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.tar.bz2
gentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.zip
Version bump KDE SC 4.12.5
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.12.5.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index 29ce12df21ad..dd1e72745cce 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.296 2014/04/17 00:43:31 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.297 2014/04/29 18:34:49 johu Exp $
+
+*superkaramba-4.12.5 (29 Apr 2014)
+
+ 29 Apr 2014; Johannes Huber <johu@gentoo.org> +superkaramba-4.12.5.ebuild:
+ Version bump KDE SC 4.12.5
16 Apr 2014; Johannes Huber <johu@gentoo.org> superkaramba-4.13.0.ebuild:
Restore KEYWORDS for KDE SC 4.13.0
diff --git a/kde-base/superkaramba/superkaramba-4.12.5.ebuild b/kde-base/superkaramba/superkaramba-4.12.5.ebuild
new file mode 100644
index 000000000000..9285856e57d6
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.12.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.12.5.ebuild,v 1.1 2014/04/29 18:34:49 johu Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+HOMEPAGE="http://www.kde.org/applications/utilities/superkaramba
+http://utils.kde.org/projects/superkaramba"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ media-libs/qimageblitz
+ x11-libs/libX11
+ x11-libs/libXrender
+ python? (
+ ${PYTHON_DEPS}
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+ )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython "${PYTHON_USEDEP}") )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}