summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
committerJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
commitc9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f (patch)
tree94015d5f29e37019f20bdced917f52e9b11645da /kde-base/superkaramba
parentAdd kde-workspace 4.11.11 SRC_URI, remove obsolete. (diff)
downloadgentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.gz
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.bz2
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.zip
Version bump KDE SC 4.13.3
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.13.3.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index c7ae02cda6f2..b5f145cce107 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.308 2014/06/19 13:32:54 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.309 2014/07/16 17:40:40 johu Exp $
+
+*superkaramba-4.13.3 (16 Jul 2014)
+
+ 16 Jul 2014; Johannes Huber <johu@gentoo.org> +superkaramba-4.13.3.ebuild:
+ Version bump KDE SC 4.13.3
19 Jun 2014; Chris Reffett <creffett@gentoo.org> -superkaramba-4.13.1.ebuild:
Remove KDE SC 4.13.1
diff --git a/kde-base/superkaramba/superkaramba-4.13.3.ebuild b/kde-base/superkaramba/superkaramba-4.13.3.ebuild
new file mode 100644
index 000000000000..a9cd017106b6
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.13.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.13.3.ebuild,v 1.1 2014/07/16 17:40:40 johu Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+HOMEPAGE="http://www.kde.org/applications/utilities/superkaramba
+http://utils.kde.org/projects/superkaramba"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ media-libs/qimageblitz
+ x11-libs/libX11
+ x11-libs/libXrender
+ python? (
+ ${PYTHON_DEPS}
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+ )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython "${PYTHON_USEDEP}") )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}