summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
commita4c1d03d518d1416c826bb73ad524dc9bf1702a5 (patch)
treed6a50377f609e5e7550ca8a99686adcdcbdbd7a1 /kde-base/step
parentRemoved unneccessary python_copy_sources (diff)
downloadgentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.gz
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.bz2
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.zip
[kde-base] Add KDE SC 4.6.1
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.6.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 0cd7fdd81b8d..b83a8ec8111f 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.66 2011/01/26 20:29:05 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.67 2011/03/04 18:00:19 alexxy Exp $
+
+*step-4.6.1 (04 Mar 2011)
+
+ 04 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> +step-4.6.1.ebuild:
+ Version bump KDE SC 4.6.1
*step-4.6.0 (26 Jan 2011)
diff --git a/kde-base/step/step-4.6.1.ebuild b/kde-base/step/step-4.6.1.ebuild
new file mode 100644
index 000000000000..d30ded85bba4
--- /dev/null
+++ b/kde-base/step/step-4.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.6.1.ebuild,v 1.1 2011/03/04 18:00:19 alexxy Exp $
+
+EAPI=3
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+
+ kde4-meta_src_configure
+}