summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
commit2e92514fb34e1f80047f1661e4193fa9a3d3a06c (patch)
treef15f05d59c776fb13bf637e65c070c72f7b65720 /kde-base/smoke
parentFix libpng SLOT depend wrt #339796 by "MaratIK". (diff)
downloadgentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.tar.gz
gentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.tar.bz2
gentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.zip
Add KDE SC 4.5.2 =)
(Portage version: 2.2_rc88_p115/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.5.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index b4739d7b2d39..3a7f86eb8206 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.115 2010/09/19 04:19:43 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.116 2010/10/06 09:17:27 alexxy Exp $
+
+*smoke-4.5.2 (05 Oct 2010)
+
+ 05 Oct 2010; Alexey Shvetsov <alexxy@gentoo.org> +smoke-4.5.2.ebuild:
+ Version bump KDE SC 4.5.2
19 Sep 2010; Jonathan Callen <abcd@gentoo.org> smoke-4.5.1.ebuild:
Add ~amd64-linux, ~x86-linux keywords
diff --git a/kde-base/smoke/smoke-4.5.2.ebuild b/kde-base/smoke/smoke-4.5.2.ebuild
new file mode 100644
index 000000000000..9b6feea671a3
--- /dev/null
+++ b/kde-base/smoke/smoke-4.5.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.5.2.ebuild,v 1.1 2010/10/06 09:17:27 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+MULTIMEDIA_REQUIRED="optional"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi attica debug okular +phonon qimageblitz qscintilla qwt semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ attica? ( dev-libs/libattica )
+ okular? ( $(add_kdebase_dep okular) )
+ phonon? ( >=media-sound/phonon-4.3.80[xcb] )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRA="generator/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-meta_src_configure
+}