summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-01-06 14:31:54 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-01-06 14:31:54 +0000
commitf57494f39283deecb80a6e149bb955cc35dc7fb6 (patch)
tree58949e8a32954d4074d8b5f937b572c4b53cd276 /kde-base/quanta
parentFix include directory wrt #204548. Respect CC and CFLAGS targets. Fix compile... (diff)
downloadgentoo-2-f57494f39283deecb80a6e149bb955cc35dc7fb6.tar.gz
gentoo-2-f57494f39283deecb80a6e149bb955cc35dc7fb6.tar.bz2
gentoo-2-f57494f39283deecb80a6e149bb955cc35dc7fb6.zip
Added an upstream patch provided by Vanya to fix bug 204289. Thanks, Vanya!
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'kde-base/quanta')
-rw-r--r--kde-base/quanta/ChangeLog10
-rw-r--r--kde-base/quanta/files/digest-quanta-3.5.8-r13
-rw-r--r--kde-base/quanta/files/quanta-3.5.8-left-over-tab-fix.diff13
-rw-r--r--kde-base/quanta/quanta-3.5.8-r1.ebuild42
4 files changed, 66 insertions, 2 deletions
diff --git a/kde-base/quanta/ChangeLog b/kde-base/quanta/ChangeLog
index 319ddb641263..910a17bf7174 100644
--- a/kde-base/quanta/ChangeLog
+++ b/kde-base/quanta/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/quanta
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/ChangeLog,v 1.76 2007/10/19 23:58:24 philantrop Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/ChangeLog,v 1.77 2008/01/06 14:31:53 philantrop Exp $
+
+*quanta-3.5.8-r1 (06 Jan 2008)
+
+ 06 Jan 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/quanta-3.5.8-left-over-tab-fix.diff, +quanta-3.5.8-r1.ebuild:
+ Added an upstream patch provided by Vanya to fix bug 204289. Thanks, Vanya!
*quanta-3.5.8 (19 Oct 2007)
diff --git a/kde-base/quanta/files/digest-quanta-3.5.8-r1 b/kde-base/quanta/files/digest-quanta-3.5.8-r1
new file mode 100644
index 000000000000..2b5d892a38c2
--- /dev/null
+++ b/kde-base/quanta/files/digest-quanta-3.5.8-r1
@@ -0,0 +1,3 @@
+MD5 6c17c4b71a4d306da4b81a0cfd3116e1 kdewebdev-3.5.8.tar.bz2 6055535
+RMD160 325d8cd569f438ca62e1141f768431ca88c70b22 kdewebdev-3.5.8.tar.bz2 6055535
+SHA256 797123337d158b160168402eccb20bf186c74c18c99bc0d4e3c4a2b02589432d kdewebdev-3.5.8.tar.bz2 6055535
diff --git a/kde-base/quanta/files/quanta-3.5.8-left-over-tab-fix.diff b/kde-base/quanta/files/quanta-3.5.8-left-over-tab-fix.diff
new file mode 100644
index 000000000000..c6f4ceb39f9e
--- /dev/null
+++ b/kde-base/quanta/files/quanta-3.5.8-left-over-tab-fix.diff
@@ -0,0 +1,13 @@
+--- kdewebdev-3.5.8/quanta/src/quantadoc.cpp 2008/01/04 15:16:23 757249
++++ kdewebdev-3.5.8-patched/quanta/src/quantadoc.cpp 2008/01/04 15:17:38 757250
+@@ -99,6 +99,10 @@
+ QuantaView *view = ViewManager::ref()->isOpened(url);
+ if (!view || newfile)
+ {
++ w = ViewManager::ref()->activeDocument();
++ if (w && !newfile && !w->isModified() && w->isUntitled() && !w->busy)
++ ViewManager::ref()->removeActiveView(false);
++
+ /*
+ // no modi and new -> we can remove !!!!
+ w = ViewManager::ref()->activeDocument();
diff --git a/kde-base/quanta/quanta-3.5.8-r1.ebuild b/kde-base/quanta/quanta-3.5.8-r1.ebuild
new file mode 100644
index 000000000000..11330b895146
--- /dev/null
+++ b/kde-base/quanta/quanta-3.5.8-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/quanta-3.5.8-r1.ebuild,v 1.1 2008/01/06 14:31:53 philantrop Exp $
+KMNAME=kdewebdev
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE: Quanta Plus Web Development Environment"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc kdehiddenvisibility"
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2"
+RDEPEND="${RDEPEND}
+doc? ( app-doc/quanta-docs )"
+
+KMCOMPILEONLY=lib
+
+PATCHES="${FILESDIR}/${P}-left-over-tab-fix.diff"
+
+# TODO: check why this wasn't needed back in the monolithic ebuild
+src_compile () {
+ myconf="--with-extra-includes=$(xml2-config --cflags | sed -e 's:^-I::')"
+ kde-meta_src_compile
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ echo
+ elog "${P} has some optional dependencies which you might want to emerge:"
+ elog "- app-text/htmltidy for HTML syntax checking."
+ elog "- app-crypt/gnupg for previewing browser configuration."
+ elog "- kde-base/kompare for comparing files by content."
+ elog "- kde-base/cervisia for enabling the CVS management plugin."
+ elog "- kde-base/kfilereplace for searching and replacing in files."
+ elog "- kde-base/kimagemapeditor for editing HTML image maps."
+ elog "- kde-base/klinkstatus for link validity checking."
+ elog "- kde-base/kxsldbg for XSLT debugging."
+ elog "- kde-base/kommander for the QuickStart dialogue and other scripted dialogues."
+ echo
+}