summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
commit8f5c0a404860825a8ca1de5f74decd3e3b2f411e (patch)
treefd54bf03f8193c4baefa01616ebd14e3b25f8717 /kde-base/qtruby
parentUse github from thirdpartymirrors. (diff)
downloadgentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.gz
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.bz2
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.zip
Version bump KDE SC 4.8.0
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog7
-rw-r--r--kde-base/qtruby/qtruby-4.8.0.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index 9518797130c7..2e998a60861f 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.98 2012/01/17 13:28:57 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.99 2012/01/25 18:17:03 johu Exp $
+
+*qtruby-4.8.0 (25 Jan 2012)
+
+ 25 Jan 2012; Johannes Huber <johu@gentoo.org> +qtruby-4.8.0.ebuild:
+ Version bump KDE SC 4.8.0
17 Jan 2012; Johannes Huber <johu@gentoo.org> -qtruby-4.7.3.ebuild:
Remove KDE SC 4.7.3
diff --git a/kde-base/qtruby/qtruby-4.8.0.ebuild b/kde-base/qtruby/qtruby-4.8.0.ebuild
new file mode 100644
index 000000000000..e467faa96c8b
--- /dev/null
+++ b/kde-base/qtruby/qtruby-4.8.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.8.0.ebuild,v 1.1 2012/01/25 18:17:03 johu Exp $
+
+EAPI=4
+
+OPENGL_REQUIRED="always"
+DECLARATIVE_REQUIRED="optional"
+KDE_REQUIRED="never"
+KDE_SCM="git"
+USE_RUBY="ruby18"
+# No ruby19 for three reasons:
+# 1) it does not build (yet) - will likely be solved soon
+# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="Qt Ruby bindings"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qscintilla qwt webkit"
+
+DEPEND="
+ $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
+"
+
+RDEPEND="${DEPEND}
+"
+
+# Split from kdebindings-ruby in 4.7
+add_blocker kdebindings-ruby
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ local CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}