summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-28 19:03:48 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-28 19:03:48 +0000
commit77b20615bb930cef6da50398d4bc456f89272bf8 (patch)
tree2e9b2c7048cfe75f38525f73bf365449c94c6ad8 /kde-base/qtruby
parentDrop KDEpim 4.6.1 and KDE 4.7.1 (diff)
downloadgentoo-2-77b20615bb930cef6da50398d4bc456f89272bf8.tar.gz
gentoo-2-77b20615bb930cef6da50398d4bc456f89272bf8.tar.bz2
gentoo-2-77b20615bb930cef6da50398d4bc456f89272bf8.zip
Drop KDEpim 4.6.1 and KDE 4.7.1
(Portage version: 2.1.10.31/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.7.1.ebuild76
2 files changed, 4 insertions, 77 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index 0cb76430faea..7ae455cdc93d 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.89 2011/10/15 17:26:01 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.90 2011/10/28 19:03:30 dilfridge Exp $
+
+ 28 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org> -qtruby-4.7.1.ebuild:
+ Drop KDEpim 4.6.1 and KDE 4.7.1
15 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org> -qtruby-4.7.0.ebuild:
Drop KDE 4.7.0
diff --git a/kde-base/qtruby/qtruby-4.7.1.ebuild b/kde-base/qtruby/qtruby-4.7.1.ebuild
deleted file mode 100644
index f618816c97e3..000000000000
--- a/kde-base/qtruby/qtruby-4.7.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.7.1.ebuild,v 1.1 2011/09/07 20:13:52 alexxy Exp $
-
-EAPI=4
-
-OPENGL_REQUIRED="always"
-DECLARATIVE_REQUIRED="optional"
-KDE_REQUIRED="never"
-KDE_SCM="git"
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="Qt Ruby bindings"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug phonon qscintilla qwt webkit"
-
-DEPEND="
- $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
-"
-
-RDEPEND="${DEPEND}
- !dev-ruby/qt4-qtruby
-"
-
-# Split from kdebindings-ruby in 4.7
-add_blocker kdebindings-ruby
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- local CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_disable declarative QtDeclarative)
- $(cmake-utils_use_with phonon)
- $(cmake-utils_use_with qscintilla QScintilla)
- $(cmake-utils_use_with qwt Qwt5)
- $(cmake-utils_use_disable webkit QtWebKit)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}