summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2013-07-02 09:30:44 +0000
committerAgostino Sarubbo <ago@gentoo.org>2013-07-02 09:30:44 +0000
commit5d6ea16a89933d6d89368dea90992d0763feb223 (patch)
tree3273e582d427985dde35732cc4b2d278ac575957 /kde-base/qtruby
parentadd justification for using .bundle iso .so (diff)
downloadgentoo-2-5d6ea16a89933d6d89368dea90992d0763feb223.tar.gz
gentoo-2-5d6ea16a89933d6d89368dea90992d0763feb223.tar.bz2
gentoo-2-5d6ea16a89933d6d89368dea90992d0763feb223.zip
Remove old
(Portage version: 2.1.12.2/cvs/Linux ppc64, RepoMan options: --force, signed Manifest commit with key 7194459F)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.10.3.ebuild74
2 files changed, 4 insertions, 75 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index 6e45788196e0..3458f31da8d2 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.164 2013/07/02 08:06:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.165 2013/07/02 09:30:39 ago Exp $
+
+ 02 Jul 2013; Agostino Sarubbo <ago@gentoo.org> -qtruby-4.10.3.ebuild:
+ Remove old
02 Jul 2013; Agostino Sarubbo <ago@gentoo.org> qtruby-4.10.4.ebuild:
Stable for ppc64, wrt to bug #473942
diff --git a/kde-base/qtruby/qtruby-4.10.3.ebuild b/kde-base/qtruby/qtruby-4.10.3.ebuild
deleted file mode 100644
index c3376bd63337..000000000000
--- a/kde-base/qtruby/qtruby-4.10.3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.10.3.ebuild,v 1.5 2013/06/08 10:09:06 ago Exp $
-
-EAPI=5
-
-OPENGL_REQUIRED="always"
-DECLARATIVE_REQUIRED="optional"
-KDE_REQUIRED="never"
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="Qt Ruby bindings"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug phonon qscintilla qwt webkit"
-
-DEPEND="
- $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
-"
-
-RDEPEND="${DEPEND}
-"
-
-# Split from kdebindings-ruby in 4.7
-add_blocker kdebindings-ruby
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- local CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_disable declarative QtDeclarative)
- $(cmake-utils_use_with phonon)
- $(cmake-utils_use_with qscintilla QScintilla)
- $(cmake-utils_use_with qwt Qwt5)
- $(cmake-utils_use_disable webkit QtWebKit)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}