summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-23 07:37:28 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-23 07:37:28 +0000
commit178018faa19cd1b2ff5e6b9e497a19d90277223f (patch)
tree5e8d3e5051377fbf91947b0a1ec7ea2b60128910 /kde-base/qtruby
parentConvert SGML_TOINSTALL to a bash array. Add some documentation. (diff)
downloadgentoo-2-178018faa19cd1b2ff5e6b9e497a19d90277223f.tar.gz
gentoo-2-178018faa19cd1b2ff5e6b9e497a19d90277223f.tar.bz2
gentoo-2-178018faa19cd1b2ff5e6b9e497a19d90277223f.zip
Remove KDE SC 4.8.0
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.8.0.ebuild75
2 files changed, 4 insertions, 76 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index a1c7b1942454..d7efc35b6d98 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.102 2012/03/06 23:35:17 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.103 2012/03/23 07:37:12 johu Exp $
+
+ 23 Mar 2012; Johannes Huber <johu@gentoo.org> -qtruby-4.8.0.ebuild:
+ Remove KDE SC 4.8.0
*qtruby-4.8.1 (06 Mar 2012)
diff --git a/kde-base/qtruby/qtruby-4.8.0.ebuild b/kde-base/qtruby/qtruby-4.8.0.ebuild
deleted file mode 100644
index e467faa96c8b..000000000000
--- a/kde-base/qtruby/qtruby-4.8.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.8.0.ebuild,v 1.1 2012/01/25 18:17:03 johu Exp $
-
-EAPI=4
-
-OPENGL_REQUIRED="always"
-DECLARATIVE_REQUIRED="optional"
-KDE_REQUIRED="never"
-KDE_SCM="git"
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="Qt Ruby bindings"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug phonon qscintilla qwt webkit"
-
-DEPEND="
- $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
-"
-
-RDEPEND="${DEPEND}
-"
-
-# Split from kdebindings-ruby in 4.7
-add_blocker kdebindings-ruby
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- local CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_disable declarative QtDeclarative)
- $(cmake-utils_use_with phonon)
- $(cmake-utils_use_with qscintilla QScintilla)
- $(cmake-utils_use_with qwt Qwt5)
- $(cmake-utils_use_disable webkit QtWebKit)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}