summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-02 10:57:42 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-02 10:57:42 +0000
commit75cfbd4b9406223c25574c71807b16f2a3ef0ed6 (patch)
tree98f58532fcff401fff57beeffd58f524260eac8a /kde-base/libplasma
parentAdd kde-4.1.2 into the tree from the kde-testing overlay. (diff)
downloadgentoo-2-75cfbd4b9406223c25574c71807b16f2a3ef0ed6.tar.gz
gentoo-2-75cfbd4b9406223c25574c71807b16f2a3ef0ed6.tar.bz2
gentoo-2-75cfbd4b9406223c25574c71807b16f2a3ef0ed6.zip
Add kde-4.1.2 into the tree from the kde-testing overlay.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'kde-base/libplasma')
-rw-r--r--kde-base/libplasma/ChangeLog8
-rw-r--r--kde-base/libplasma/libplasma-4.1.2.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/kde-base/libplasma/ChangeLog b/kde-base/libplasma/ChangeLog
index 14bbde223b13..b26365a8e169 100644
--- a/kde-base/libplasma/ChangeLog
+++ b/kde-base/libplasma/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/libplasma
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/ChangeLog,v 1.10 2008/06/09 14:57:25 keytoaster Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/ChangeLog,v 1.11 2008/10/02 10:57:42 jmbsvicetto Exp $
+
+*libplasma-4.1.2 (02 Oct 2008)
+
+ 02 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +libplasma-4.1.2.ebuild:
+ Add kde-4.1.2 into the tree from the kde-testing overlay.
09 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org>
-libplasma-4.0.2.ebuild, -libplasma-4.0.3.ebuild:
diff --git a/kde-base/libplasma/libplasma-4.1.2.ebuild b/kde-base/libplasma/libplasma-4.1.2.ebuild
new file mode 100644
index 000000000000..7bea4c422fd1
--- /dev/null
+++ b/kde-base/libplasma/libplasma-4.1.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/libplasma-4.1.2.ebuild,v 1.1 2008/10/02 10:57:42 jmbsvicetto Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-workspace
+KMMODULE="libs/plasma"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Plasma: KDE desktop framework"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl xinerama"
+
+RDEPEND=">=app-misc/strigi-0.5.11[qt4]
+ !<kde-base/plasma-3.96.0
+ >=kde-base/libkworkspace-${PV}:${SLOT}
+ >=kde-base/libtaskmanager-${PV}:${SLOT}
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/qt-webkit:4[debug?]
+ opengl? ( virtual/opengl )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+KMEXTRACTONLY="krunner/org.freedesktop.ScreenSaver.xml
+ krunner/org.kde.krunner.Interface.xml
+ ksmserver/org.kde.KSMServerInterface.xml
+ libs/taskmanager/"
+KMSAVELIBS="true"
+
+# Disabling tests for now. 3 out of 3 broken now. last tested on 4.0.1.
+RESTRICT="test"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # Outsmart our doc-handling, to avoid a collision with plasma.
+ rm -rf "${D}"/${KDEDIR}/share/doc/
+}