summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
commitaa3564c24799d7ef9148aa35aa2294090c7d0672 (patch)
tree564f76c48c05f07f04c01e801b11d91042e6830f /kde-base/ktimetracker/ktimetracker-4.7.4.ebuild
parentAdd 3.0 documentation (diff)
downloadgentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.tar.gz
gentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.tar.bz2
gentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.zip
[kde-base] Add long waiting KDE SC 4.7.4
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ktimetracker/ktimetracker-4.7.4.ebuild')
-rw-r--r--kde-base/ktimetracker/ktimetracker-4.7.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/ktimetracker/ktimetracker-4.7.4.ebuild b/kde-base/ktimetracker/ktimetracker-4.7.4.ebuild
new file mode 100644
index 000000000000..d060b753dd9b
--- /dev/null
+++ b/kde-base/ktimetracker/ktimetracker-4.7.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ktimetracker/ktimetracker-4.7.4.ebuild,v 1.1 2011/12/11 18:52:41 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+KDE_SCM="git"
+inherit kde4-meta
+
+DESCRIPTION="KTimeTracker tracks time spent on various tasks."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdebase_dep kdepim-kresources)
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kdepim-common-libs)
+ x11-libs/libXScrnSaver
+"
+DEPEND="${RDEPEND}
+ x11-proto/scrnsaverproto
+"
+
+KMEXTRACTONLY="
+ kresources/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+src_unpack() {
+ if use kontact; then
+ KMEXTRA="${KMEXTRA} kontact/plugins/ktimetracker"
+ fi
+
+ kde4-meta_src_unpack
+}