summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
commitdcee7201ef2606358a4f2abc45af713ef2555e5a (patch)
treedac1ea20988f395333c20c4985b60f84f2e71a82 /kde-base/krunner
parentbump to the TeX Live 2011 version (diff)
downloadgentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.gz
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.bz2
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.zip
[kde-base] Version bump KDE SC 4.7.0
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/krunner')
-rw-r--r--kde-base/krunner/ChangeLog7
-rw-r--r--kde-base/krunner/krunner-4.7.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/krunner/ChangeLog b/kde-base/krunner/ChangeLog
index 34a560a77913..9dc760400cce 100644
--- a/kde-base/krunner/ChangeLog
+++ b/kde-base/krunner/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/krunner
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/krunner/ChangeLog,v 1.99 2011/07/09 15:14:21 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/krunner/ChangeLog,v 1.100 2011/07/27 14:04:48 alexxy Exp $
+
+*krunner-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +krunner-4.7.0.ebuild:
+ Version bump KDE SC 4.7.0
*krunner-4.6.5 (09 Jul 2011)
diff --git a/kde-base/krunner/krunner-4.7.0.ebuild b/kde-base/krunner/krunner-4.7.0.ebuild
new file mode 100644
index 000000000000..c3462e0d1348
--- /dev/null
+++ b/kde-base/krunner/krunner-4.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/krunner/krunner-4.7.0.ebuild,v 1.1 2011/07/27 14:04:48 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE Command Runner"
+IUSE="debug"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kcheckpass)
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep ksmserver)
+ $(add_kdebase_dep ksysguard)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep libplasmagenericshell)
+ !aqua? (
+ x11-libs/libXcursor
+ x11-libs/libXScrnSaver
+ )
+"
+DEPEND="${COMMONDEPEND}
+ !aqua? (
+ x11-libs/libXcursor
+ x11-proto/scrnsaverproto
+ )
+"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}"-4.6.2-noxf86misc.patch )
+
+KMEXTRACTONLY="
+ libs/kdm/
+ libs/kephal/
+ libs/ksysguard/
+ libs/kworkspace/
+ libs/plasmagenericshell/
+ kcheckpass/
+ ksmserver/org.kde.KSMServerInterface.xml
+ ksysguard/
+ plasma/screensaver/shell/org.kde.plasma-overlay.App.xml
+"
+
+KMLOADLIBS="libkworkspace"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}