summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-02 12:26:25 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-02 12:26:25 +0000
commit21209a90781772d6317385885f68a488e21205ba (patch)
treee0ec376fc7d9f96e20b2b62790767d0a283ca337 /kde-base/kopete
parentAdded missing use flags descriptions. (diff)
downloadgentoo-2-21209a90781772d6317385885f68a488e21205ba.tar.gz
gentoo-2-21209a90781772d6317385885f68a488e21205ba.tar.bz2
gentoo-2-21209a90781772d6317385885f68a488e21205ba.zip
Added missing use flags descriptions.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog8
-rw-r--r--kde-base/kopete/kopete-4.1.2.ebuild107
-rw-r--r--kde-base/kopete/metadata.xml60
3 files changed, 148 insertions, 27 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index e126cb355bb2..c710d5ba511b 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.157 2008/09/30 03:10:37 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.158 2008/10/02 12:26:25 jmbsvicetto Exp $
+
+*kopete-4.1.2 (02 Oct 2008)
+
+ 02 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ metadata.xml, +kopete-4.1.2.ebuild:
+ Add kde-4.1.2 into the tree from the kde-testing overlay.
30 Sep 2008; Ryan Hill <dirtyepic@gentoo.org>
+files/kopete-3.5.10-gcc43.patch, kopete-3.5.10.ebuild:
diff --git a/kde-base/kopete/kopete-4.1.2.ebuild b/kde-base/kopete/kopete-4.1.2.ebuild
new file mode 100644
index 000000000000..8b119a41f5e7
--- /dev/null
+++ b/kde-base/kopete/kopete-4.1.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.1.2.ebuild,v 1.1 2008/10/02 12:26:25 jmbsvicetto Exp $
+
+EAPI="2"
+
+KMNAME=kdenetwork
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS="~amd64 ~x86"
+IUSE="+addbookmarks +alias +autoreplace +contactnotes debug gadu groupwise
+ +highlight +history htmlhandbook +jabber latex messenger +msn +nowlistening
+ +oscar +otr +pipes +privacy qq sms ssl +statistics testbed +texteffect
+ +translator +urlpicpreview +webpresence winpopup yahoo"
+# IUSE="irc jingle meanwhile telepathy"
+
+# plugins: addbookmarks, alias, autoreplace, contactnotes, highlight, history,
+# latex, nowlistening, otr, pipes, privacy, (sqlite?) statistics, texteffect,
+# translator, urlpicpreview, (&& xml2 xslt) webpresence
+
+# protocols: (ssl?) gadu, (qca2?) groupwise, irc (disabled), (&& qca2 idn) jabber,
+# jingle (disabled), meanwhile (not ported), messenger (not ready), msn, oscar,
+# qq, sms, (decibel?) telepathy (not ready), testbed, winpopup, yahoo
+
+# irc and jingle are disabled in the package (4.1.0)
+# meanwhile hasn't been ported to KDE4 yet (4.1.0)
+# telepathy seems to not be ready yet and there's no decibel release (4.1.0)
+
+# Tests are KDE-ish.
+RESTRICT="test"
+
+COMMONDEPEND="dev-libs/libpcre
+ kde-base/qimageblitz
+ x11-libs/libXScrnSaver
+ gadu? ( dev-libs/openssl )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? ( net-dns/libidn app-crypt/qca:2 )
+ otr? ( net-libs/libotr )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )"
+
+RDEPEND="${COMMONDEPEND}"
+# telepathy? ( net-libs/decibel )
+
+DEPEND="${COMMONDEPEND}
+ x11-proto/scrnsaverproto"
+
+PDEPEND="ssl? ( >=app-crypt/qca-ossl-2.0.0_beta3 )"
+
+src_configure() {
+ # Xmms isn't in portage, thus forcefully disabled.
+ mycmakeargs="${mycmakeargs}
+ -DWITH_Xmms=OFF
+ -DWITH_Telepathy=OFF -DWITH_Decibel=OFF
+ $(cmake-utils_use_with addbookmarks)
+ $(cmake-utils_use_with alias)
+ $(cmake-utils_use_with autoreplace)
+ $(cmake-utils_use_with contactnotes)
+ $(cmake-utils_use_with gadu)
+ $(cmake-utils_use_with gadu OPENSSL)
+ $(cmake-utils_use_with groupwise)
+ $(cmake-utils_use_with groupwise QCA2)
+ $(cmake-utils_use_with highlight)
+ $(cmake-utils_use_with history)
+ $(cmake-utils_use_with jabber IDN)
+ $(cmake-utils_use_with jabber QCA2)
+ $(cmake-utils_use_with latex)
+ $(cmake-utils_use_with messenger)
+ $(cmake-utils_use_with msn)
+ $(cmake-utils_use_with nowlistening)
+ $(cmake-utils_use_with oscar)
+ $(cmake-utils_use_with otr)
+ $(cmake-utils_use_with pipes)
+ $(cmake-utils_use_with privacy)
+ $(cmake-utils_use_with qq)
+ $(cmake-utils_use_with sms)
+ $(cmake-utils_use_with statistics Sqlite)
+ $(cmake-utils_use_with statistics)
+ $(cmake-utils_use_with testbed)
+ $(cmake-utils_use_with texteffect)
+ $(cmake-utils_use_with translator)
+ $(cmake-utils_use_with urlpicpreview)
+ $(cmake-utils_use_with webpresence LibXml2)
+ $(cmake-utils_use_with webpresence LibXslt)
+ $(cmake-utils_use_with webpresence)
+ $(cmake-utils_use_with winpopup)
+ $(cmake-utils_use_with yahoo)
+ "
+# $(cmake-utils_use_with telepathy)
+# $(cmake-utils_use_with telepathy Decibel)
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ if use telepathy; then
+ elog "To use kopete telepathy plugins, you need to start gabble first:"
+ elog "GABBLE_PERSIST=1 telepathy-gabble &"
+ elog "export TELEPATHY_DATA_PATH=/usr/share/telepathy/managers/"
+ fi
+ if use jabber || use messenger; then
+ echo
+ elog "In order to use ssl in jabber, messenger and irc you'll need to have qca-ossl"
+ echo
+ fi
+}
diff --git a/kde-base/kopete/metadata.xml b/kde-base/kopete/metadata.xml
index 4dddd9d4d6b7..0120e59d05ba 100644
--- a/kde-base/kopete/metadata.xml
+++ b/kde-base/kopete/metadata.xml
@@ -1,30 +1,38 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>kde</herd>
- <use>
- <flag name="addbookmarks">Builds Add Bookmarks plugin</flag>
- <flag name="alias">Builds Alias plugin</flag>
- <flag name="autoreplace">Builds Auto-Replace plugin</flag>
- <flag name="connectionstatus">Builds Connection Status plugin</flag>
- <flag name="contactnotes">Builds Contact Notes plugin</flag>
- <flag name="gadu">Builds GaduGadu protocol handler</flag>
- <flag name="groupwise">Builds Novell GroupWise protocol handler</flag>
- <flag name="highlight">Builds Highlight plugin</flag>
- <flag name="history">Builds history plugin</flag>
- <flag name="irc">Builds IRC protocol handler</flag>
- <flag name="netmeeting">Builds netmeeting plugin (require gnomemeeting)</flag>
- <flag name="nowlistening">Builds Now Listening... plugin</flag>
- <flag name="privacy">plugin to selectively filter messages</flag>
- <flag name="qq">enable support for the chinese network protocol</flag>
- <flag name="sametime">Enables support for the Sametime protocol for instant messaging</flag>
- <flag name="sms">Builds SMS protocol handler</flag>
- <flag name="statistics">Builds statistics plugin</flag>
- <flag name="testbed">Enable the testbed protocol plugin</flag>
- <flag name="texteffect">Builds Text Effect plugin</flag>
- <flag name="translator">Builds Translator plugin</flag>
- <flag name="urlpicpreview">plugin to allow users to send photos through URLs</flag>
- <flag name="webpresence">Builds Web Presence plugin</flag>
- <flag name="winpopup">Builds WinPopUp protocol handler</flag>
- </use>
+<use>
+ <flag name="addbookmarks">Enable the addbookmarks plugin</flag>
+ <flag name="alias">Enable the alias plugin</flag>
+ <flag name="autoreplace">Enable the autoreplace plugin</flag>
+ <flag name="connectionstatus">Builds Connection Status plugin</flag>
+ <flag name="contactnotes">Enable the contactnotes plugin</flag>
+ <flag name="decibel">Enable the Telepathy protocol plugin</flag>
+ <flag name="gadu">Enable the gadu protocol plugin</flag>
+ <flag name="groupwise">Enable the groupwise protocol plugin</flag>
+ <flag name="highlight">Enable the highlight plugin</flag>
+ <flag name="history">Enable the history plugin</flag>
+ <flag name="irc">Builds IRC protocol handler</flag>
+ <flag name="jabber">Enable the Jabber protocol plugin</flag>
+ <flag name="nowlistening">Enable the nowlistening plugin</flag>
+ <flag name="messenger">Enable the Windows LIVE!-Messenger protocol plugin</flag>
+ <flag name="netmeeting">Builds netmeeting plugin (require gnomemeeting)</flag>
+ <flag name="otr">Encryption for IMs, using libotr</flag>
+ <flag name="pipes">Enable support for the pipes plugin</flag>
+ <flag name="privacy">plugin to selectively filter messages</flag>
+ <flag name="qca">Enable the Qt Cryptographic Architecture</flag>
+ <flag name="qq">enable support for the chinese network protocol</flag>
+ <flag name="sametime">Enables support for the Sametime protocol for instant messaging</flag>
+ <flag name="sms">Enable the sms protocol plugin</flag>
+ <flag name="statistics">Enable the statistics plugin</flag>
+ <flag name="telepathy">Enable support for the realtime communication framework telepathy</flag>
+ <flag name="testbed">Enable the testbed protocol plugin</flag>
+ <flag name="texteffect">Enable the texteffect plugin</flag>
+ <flag name="translator">Enable the translator plugin</flag>
+ <flag name="urlpicpreview">plugin to allow users to send photos through URLs</flag>
+ <flag name="xslt">Enable xslt support</flag>
+ <flag name="webpresence">Enable the webpresence plugin</flag>
+ <flag name="winpopup">Enable support for the winpopup plugin</flag>
+</use>
+<herd>kde</herd>
</pkgmetadata>