summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-04 13:33:25 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-04 13:33:25 +0000
commitec994bbd4d116fa14102b4b572d9713619ac9ac8 (patch)
tree4ddf05788dfd957d8175faa6bff593b966c0bba5 /kde-base/kmail
parentdrop support for freebsd5 and honour profile useflag for fbsd 8 and later (diff)
downloadgentoo-2-ec994bbd4d116fa14102b4b572d9713619ac9ac8.tar.gz
gentoo-2-ec994bbd4d116fa14102b4b572d9713619ac9ac8.tar.bz2
gentoo-2-ec994bbd4d116fa14102b4b572d9713619ac9ac8.zip
Add upstream patch to fix build with Qt 4.7 wrt #414569. Thanks to upstream maintainer Montel Laurent.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog7
-rw-r--r--kde-base/kmail/files/kmail-4.8.3-qt47-compat.patch13
-rw-r--r--kde-base/kmail/kmail-4.8.3.ebuild4
3 files changed, 22 insertions, 2 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 173cff2b1867..34166d22de7d 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.281 2012/05/03 20:08:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.282 2012/05/04 13:33:25 johu Exp $
+
+ 04 May 2012; Johannes Huber <johu@gentoo.org>
+ +files/kmail-4.8.3-qt47-compat.patch, kmail-4.8.3.ebuild:
+ Add upstream patch to fix build with Qt 4.7 wrt #414569. Thanks to upstream
+ maintainer Montel Laurent.
*kmail-4.8.3 (03 May 2012)
diff --git a/kde-base/kmail/files/kmail-4.8.3-qt47-compat.patch b/kde-base/kmail/files/kmail-4.8.3-qt47-compat.patch
new file mode 100644
index 000000000000..a6c553260feb
--- /dev/null
+++ b/kde-base/kmail/files/kmail-4.8.3-qt47-compat.patch
@@ -0,0 +1,13 @@
+--- a/messageviewer/viewer_p.cpp
++++ b/messageviewer/viewer_p.cpp
+@@ -1930,8 +1930,10 @@ void ViewerPrivate::slotToggleHtmlMode()
+
+ void ViewerPrivate::slotFind()
+ {
++#if QT_VERSION >= 0x040800
+ if ( mViewer->hasSelection() )
+ mFindBar->setText( mViewer->selectedText() );
++#endif
+ mFindBar->show();
+ mFindBar->focusAndSetCursor();
+ }
diff --git a/kde-base/kmail/kmail-4.8.3.ebuild b/kde-base/kmail/kmail-4.8.3.ebuild
index 28b73116b57e..79708ced9d3f 100644
--- a/kde-base/kmail/kmail-4.8.3.ebuild
+++ b/kde-base/kmail/kmail-4.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.8.3.ebuild,v 1.1 2012/05/03 20:08:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.8.3.ebuild,v 1.2 2012/05/04 13:33:25 johu Exp $
EAPI=4
@@ -55,6 +55,8 @@ KMEXTRA="
KMLOADLIBS="kdepim-common-libs"
+PATCHES=( "${FILESDIR}/${P}-qt47-compat.patch" )
+
src_configure() {
# Bug 308903
use ppc64 && append-flags -mminimal-toc