summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-05-20 22:23:08 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-05-20 22:23:08 +0000
commitddc8189090ead660629314e232a584d60d511756 (patch)
tree72800af3b16b2dbcfdeb50f57fd4831d98ae39df /kde-base/kdeutils/kdeutils-3.5.6-r1.ebuild
parentVersion bump, fixes bug #177878. (diff)
downloadgentoo-2-ddc8189090ead660629314e232a584d60d511756.tar.gz
gentoo-2-ddc8189090ead660629314e232a584d60d511756.tar.bz2
gentoo-2-ddc8189090ead660629314e232a584d60d511756.zip
klaptopdaemon: Disable pointless binary checksum, bug #178554. Avoid unauthorised access when the system is supposed to be locked & hibernated, KDE bug #143859.
(Portage version: 2.1.2.7)
Diffstat (limited to 'kde-base/kdeutils/kdeutils-3.5.6-r1.ebuild')
-rw-r--r--kde-base/kdeutils/kdeutils-3.5.6-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/kde-base/kdeutils/kdeutils-3.5.6-r1.ebuild b/kde-base/kdeutils/kdeutils-3.5.6-r1.ebuild
new file mode 100644
index 000000000000..ad1950dcbe7b
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-3.5.6-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-3.5.6-r1.ebuild,v 1.1 2007/05/20 22:23:08 carlo Exp $
+
+inherit kde-dist eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdeutils-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KDE utilities."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt kdehiddenvisibility pbbuttonsd snmp"
+
+BOTH_DEPEND="~kde-base/kdebase-${PV}
+ snmp? ( net-analyzer/net-snmp )
+ pbbuttonsd? ( app-laptop/pbbuttonsd )
+ dev-lang/python
+ dev-libs/gmp
+ x11-libs/libXtst"
+
+RDEPEND="${BOTH_DEPEND}
+ crypt? ( app-crypt/gnupg )
+ !x11-misc/superkaramba"
+
+DEPEND="${BOTH_DEPEND}
+ x11-libs/libX11
+ x11-proto/xproto
+ virtual/os-headers"
+
+src_unpack() {
+ kde_src_unpack
+ sed -i -e "s:Hidden=true:Hidden=false:" ksim/ksim.desktop || die "sed failed"
+}
+
+src_compile() {
+ local myconf="$(use_with snmp) $(use_with pbbuttonsd powerbook)
+ --without-xmms"
+
+ use crypt || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kgpg"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ # see bug 144731
+ rm ${D}${KDEDIR}/share/applications/kde/ksim.desktop
+}