summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-24 15:17:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-24 15:17:48 +0000
commit41fc79b63fe00e40c5f6e04a2530d4fa30fa6561 (patch)
treef1ae7dff7ab52082d974b6727481bd42937d1666 /kde-base/kdesktop
parentRemove old version (diff)
downloadgentoo-2-41fc79b63fe00e40c5f6e04a2530d4fa30fa6561.tar.gz
gentoo-2-41fc79b63fe00e40c5f6e04a2530d4fa30fa6561.tar.bz2
gentoo-2-41fc79b63fe00e40c5f6e04a2530d4fa30fa6561.zip
Add a patch to improve xinerama support, by Lubos Lunak.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'kde-base/kdesktop')
-rw-r--r--kde-base/kdesktop/ChangeLog8
-rw-r--r--kde-base/kdesktop/files/digest-kdesktop-3.5.5-r16
-rw-r--r--kde-base/kdesktop/files/kdesktop-3.5.5-seli-xinerama.patch87
-rw-r--r--kde-base/kdesktop/kdesktop-3.5.5-r1.ebuild54
4 files changed, 154 insertions, 1 deletions
diff --git a/kde-base/kdesktop/ChangeLog b/kde-base/kdesktop/ChangeLog
index 92126ff609dc..0759f758d8d7 100644
--- a/kde-base/kdesktop/ChangeLog
+++ b/kde-base/kdesktop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdesktop
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.70 2006/11/18 17:25:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.71 2006/11/24 15:17:48 flameeyes Exp $
+
+*kdesktop-3.5.5-r1 (24 Nov 2006)
+
+ 24 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kdesktop-3.5.5-seli-xinerama.patch, +kdesktop-3.5.5-r1.ebuild:
+ Add a patch to improve xinerama support, by Lubos Lunak.
18 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> -kdesktop-3.5.3.ebuild,
-kdesktop-3.5.3-r1.ebuild, -kdesktop-3.5.4.ebuild,
diff --git a/kde-base/kdesktop/files/digest-kdesktop-3.5.5-r1 b/kde-base/kdesktop/files/digest-kdesktop-3.5.5-r1
new file mode 100644
index 000000000000..f51965cf1cbe
--- /dev/null
+++ b/kde-base/kdesktop/files/digest-kdesktop-3.5.5-r1
@@ -0,0 +1,6 @@
+MD5 420445e2dbddfd83ebc25e85a9b9cdda kdebase-3.5-patchset-03.tar.bz2 21409
+RMD160 941b919097d03347b10bccb51db2fa5e89d7ba16 kdebase-3.5-patchset-03.tar.bz2 21409
+SHA256 59c691754627f78daf7693e82496d808cf1cc31e2d6f32af829ec4ccfd776574 kdebase-3.5-patchset-03.tar.bz2 21409
+MD5 0c685af1cbca75f9c77b3ed231ba0468 kdebase-3.5.5.tar.bz2 23851886
+RMD160 6cf804de0487347a3e1d4ea6e5ba5114d23d9806 kdebase-3.5.5.tar.bz2 23851886
+SHA256 f77632e44214648e2d0adfe1a79dd61a6a738c21fe5abb0baff16b72432baaa0 kdebase-3.5.5.tar.bz2 23851886
diff --git a/kde-base/kdesktop/files/kdesktop-3.5.5-seli-xinerama.patch b/kde-base/kdesktop/files/kdesktop-3.5.5-seli-xinerama.patch
new file mode 100644
index 000000000000..18e637d2b470
--- /dev/null
+++ b/kde-base/kdesktop/files/kdesktop-3.5.5-seli-xinerama.patch
@@ -0,0 +1,87 @@
+Index: kdebase-3.5.5/kdesktop/desktop.cc
+===================================================================
+--- kdebase-3.5.5.orig/kdesktop/desktop.cc
++++ kdebase-3.5.5/kdesktop/desktop.cc
+@@ -516,9 +516,12 @@ void KDesktop::popupExecuteCommand(const
+ if ( m_miniCli->isVisible() ) {
+ KWin::forceActiveWindow( m_miniCli->winId() );
+ } else {
+- QRect rect = KGlobalSettings::desktopGeometry(QCursor::pos());
+- m_miniCli->move(rect.x() + (rect.width() - m_miniCli->width())/2,
+- rect.y() + (rect.height() - m_miniCli->height())/2);
++ NETRootInfo i( qt_xdisplay(), NET::Supported );
++ if( !i.isSupported( NET::WM2FullPlacement )) {
++ QRect rect = KGlobalSettings::desktopGeometry(QCursor::pos());
++ m_miniCli->move(rect.x() + (rect.width() - m_miniCli->width())/2,
++ rect.y() + (rect.height() - m_miniCli->height())/2);
++ }
+ m_miniCli->show(); // non-modal
+ }
+ }
+Index: kdebase-3.5.5/kdesktop/minicli.cpp
+===================================================================
+--- kdebase-3.5.5.orig/kdesktop/minicli.cpp
++++ kdebase-3.5.5/kdesktop/minicli.cpp
+@@ -369,6 +369,17 @@ int Minicli::runCommand()
+ cmd = uri.path();
+ else
+ cmd = uri.url();
++
++ QCString asn;
++ if( qApp->desktop()->isVirtualDesktop())
++ {
++ asn = KStartupInfo::createNewStartupId();
++ KStartupInfoId id;
++ id.initId( asn );
++ KStartupInfoData data;
++ data.setXinerama( qApp->desktop()->screenNumber( this ));
++ KStartupInfo::sendChange( id, data );
++ }
+
+ // Determine whether the application should be run through
+ // the command line (terminal) interface...
+@@ -504,7 +515,7 @@ int Minicli::runCommand()
+ case KURIFilterData::HELP:
+ {
+ // No need for kfmclient, KRun does it all (David)
+- (void) new KRun( m_filterData->uri(), parentWidget());
++ (void) new KRun( m_filterData->uri(), parentWidget(), asn );
+ return 0;
+ }
+ case KURIFilterData::EXECUTABLE:
+@@ -516,7 +527,7 @@ int Minicli::runCommand()
+ if (service && service->isValid() && service->type() == "Application")
+ {
+ notifyServiceStarted(service);
+- KRun::run(*service, KURL::List());
++ KRun::run(*service, KURL::List(), parentWidget(), asn );
+ return 0;
+ }
+ }
+@@ -551,7 +562,7 @@ int Minicli::runCommand()
+ if (service && service->isValid() && service->type() == "Application")
+ {
+ notifyServiceStarted(service);
+- KRun::run(*service, KURL::List(), this);
++ KRun::run(*service, KURL::List(), parentWidget(), asn );
+ return 0;
+ }
+
+@@ -559,7 +570,7 @@ int Minicli::runCommand()
+ if (service && service->isValid() && service->type() == "Application")
+ {
+ notifyServiceStarted(service);
+- KRun::run(*service, KURL::List(), this);
++ KRun::run(*service, KURL::List(), parentWidget(), asn );
+ return 0;
+ }
+
+@@ -571,7 +582,7 @@ int Minicli::runCommand()
+ }
+ }
+
+- if ( KRun::runCommand( cmd, exec, m_iconName ) )
++ if ( KRun::runCommand( cmd, exec, m_iconName, parentWidget(), asn ) )
+ return 0;
+ else
+ {
diff --git a/kde-base/kdesktop/kdesktop-3.5.5-r1.ebuild b/kde-base/kdesktop/kdesktop-3.5.5-r1.ebuild
new file mode 100644
index 000000000000..3c0513b3ccba
--- /dev/null
+++ b/kde-base/kdesktop/kdesktop-3.5.5-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/kdesktop-3.5.5-r1.ebuild,v 1.1 2006/11/24 15:17:48 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="KDesktop is the KDE interface that handles the icons, desktop popup menus and the screensaver system."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="xscreensaver"
+
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkonq)
+ $(deprange $PV $MAXKDEVER kde-base/kcontrol)
+ xscreensaver? ( || ( x11-proto/scrnsaverproto <virtual/x11-7 ) )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+RDEPEND="${DEPEND}
+ $(deprange 3.5.0 $MAXKDEVER kde-base/kcheckpass)
+ $(deprange $PV $MAXKDEVER kde-base/kdialog)
+ $(deprange $PV $MAXKDEVER kde-base/konqueror)
+ xscreensaver? ( || ( x11-libs/libXScrnSaver <virtual/x11-7 ) )"
+
+KMCOPYLIB="libkonq libkonq/"
+KMEXTRACTONLY="kcheckpass/kcheckpass.h
+ libkonq/
+ kdm/kfrontend/themer/
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+KMCOMPILEONLY="kcontrol/background
+ kdmlib/"
+KMNODOCS=true
+
+PATCHES="${FILESDIR}/${P}-seli-xinerama.patch"
+
+src_compile() {
+ myconf="${myconf} $(use_with xscreensaver)"
+ kde-meta_src_compile
+}
+
+src_install() {
+ # ugly, needs fixing: don't install kcontrol/background
+ kde-meta_src_install
+
+ rmdir "${D}/${PREFIX}/share/templates/.source/emptydir"
+}
+
+pkg_postinst() {
+ mkdir -p "${PREFIX}/share/templates/.source/emptydir"
+}