summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 19:03:33 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 19:03:33 +0000
commitdc14d2bd2ee7a2b9a171c9883b068ca8249be6c6 (patch)
treec906e4316d67f58f79313aa7fcb955b19e39ee33 /kde-base/kdepimlibs
parentVersion bump KDE 4.3.2 (diff)
downloadgentoo-2-dc14d2bd2ee7a2b9a171c9883b068ca8249be6c6.tar.gz
gentoo-2-dc14d2bd2ee7a2b9a171c9883b068ca8249be6c6.tar.bz2
gentoo-2-dc14d2bd2ee7a2b9a171c9883b068ca8249be6c6.zip
Version bump KDE 4.3.2
(Portage version: 2.2_rc44/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.3.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 6661dec3209a..8006e8a6709b 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.37 2009/09/01 15:15:01 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.38 2009/10/06 19:03:33 alexxy Exp $
+
+*kdepimlibs-4.3.2 (06 Oct 2009)
+
+ 06 Oct 2009; Alexey Shvetsov <alexxy@gentoo.org> +kdepimlibs-4.3.2.ebuild:
+ Version bump
*kdepimlibs-4.3.1 (01 Sep 2009)
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.3.2.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.3.2.ebuild
new file mode 100644
index 000000000000..8f39782c53f4
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.3.2.ebuild,v 1.1 2009/10/06 19:03:33 alexxy Exp $
+
+EAPI="2"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+IUSE="debug +handbook ldap"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.2.0
+ dev-libs/boost
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ ldap? ( net-nds/openldap )
+"
+# @since 4.3 - libkholidays is in kdepimlibs now
+RDEPEND="${DEPEND}
+ !kdeprefix? (
+ !kde-base/akonadi:4.1[-kdeprefix]
+ !kde-base/libkholidays:4.1[-kdeprefix]
+ !kde-base/libkholidays:4.2[-kdeprefix]
+ )
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)"
+
+ kde4-base_src_configure
+}