summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-17 00:37:20 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-17 00:37:20 +0000
commit5de1e54d769167e702e0020b00557971f3a1354a (patch)
treef8996b3378bc33734d3d2f8c5b990df7e3974209 /kde-base/kdegraphics
parentstable on ia64 (Manifest recommit) (diff)
downloadgentoo-2-5de1e54d769167e702e0020b00557971f3a1354a.tar.gz
gentoo-2-5de1e54d769167e702e0020b00557971f3a1354a.tar.bz2
gentoo-2-5de1e54d769167e702e0020b00557971f3a1354a.zip
~hppa
Diffstat (limited to 'kde-base/kdegraphics')
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.2.0.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/kde-base/kdegraphics/kdegraphics-3.2.0.ebuild b/kde-base/kdegraphics/kdegraphics-3.2.0.ebuild
index cd6f2103f4fc..ea4042969320 100644
--- a/kde-base/kdegraphics/kdegraphics-3.2.0.ebuild
+++ b/kde-base/kdegraphics/kdegraphics-3.2.0.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.2.0.ebuild,v 1.5 2004/02/15 17:12:06 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.2.0.ebuild,v 1.6 2004/02/17 00:37:20 vapier Exp $
+
inherit kde-dist
-IUSE="gphoto2 tetex scanner opengl"
DESCRIPTION="KDE graphics-related apps"
-KEYWORDS="x86 sparc ~amd64 ppc"
+KEYWORDS="x86 ppc sparc ~hppa ~amd64"
+IUSE="gphoto2 tetex scanner opengl"
DEPEND="~kde-base/kdebase-${PV}
gphoto2? ( media-gfx/gphoto2 )
@@ -18,17 +19,20 @@ DEPEND="~kde-base/kdebase-${PV}
virtual/ghostscript
media-libs/tiff
x86? ( scanner? sys-libs/libieee1284 )"
+RDEPEND="${DEPEND}
+ app-text/xpdf"
-RDEPEND="$DEPEND app-text/xpdf"
-
-use gphoto2 && myconf="$myconf --with-kamera \
+src_compile() {
+ use gphoto2 \
+ && myconf="$myconf --with-kamera \
--with-gphoto2-includes=/usr/include/gphoto2 \
- --with-gphoto2-libraries=/usr/lib/gphoto2" || \
- myconf="$myconf --without-kamera"
-
-use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+ --with-gphoto2-libraries=/usr/lib/gphoto2" \
+ || myconf="$myconf --without-kamera"
-use scanner || DO_NOT_COMPILE="$DO_NOT_COMPILE kooka libkscan"
+ use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
-myconf="$myconf --with-imlib --with-imlib-config=/usr/bin"
+ use scanner || DO_NOT_COMPILE="$DO_NOT_COMPILE kooka libkscan"
+ myconf="$myconf --with-imlib --with-imlib-config=/usr/bin"
+ kde_src_compile
+}