summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 22:49:46 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 22:49:46 +0000
commit393e4519299a8e99b3c76bb6e5024bfe911db66d (patch)
treee235aea29f8af00778b9475e9766fc77927ce2c0 /kde-base/kdegraphics-kfile-plugins
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-393e4519299a8e99b3c76bb6e5024bfe911db66d.tar.gz
gentoo-2-393e4519299a8e99b3c76bb6e5024bfe911db66d.tar.bz2
gentoo-2-393e4519299a8e99b3c76bb6e5024bfe911db66d.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kdegraphics-kfile-plugins')
-rw-r--r--kde-base/kdegraphics-kfile-plugins/ChangeLog8
-rw-r--r--kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.9.ebuild25
2 files changed, 32 insertions, 1 deletions
diff --git a/kde-base/kdegraphics-kfile-plugins/ChangeLog b/kde-base/kdegraphics-kfile-plugins/ChangeLog
index 8211e68ef445..ddd2a817f10c 100644
--- a/kde-base/kdegraphics-kfile-plugins/ChangeLog
+++ b/kde-base/kdegraphics-kfile-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdegraphics-kfile-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/ChangeLog,v 1.92 2008/02/19 04:20:29 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/ChangeLog,v 1.93 2008/02/20 22:49:46 philantrop Exp $
+
+*kdegraphics-kfile-plugins-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdegraphics-kfile-plugins-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
19 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
kdegraphics-kfile-plugins-3.5.5-r1.ebuild:
diff --git a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.9.ebuild b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.9.ebuild
new file mode 100644
index 000000000000..8a4431ebb0ec
--- /dev/null
+++ b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.9.ebuild,v 1.1 2008/02/20 22:49:46 philantrop Exp $
+
+KMNAME=kdegraphics
+KMMODULE=kfile-plugins
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="kfile plugins from kdegraphics"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="openexr"
+DEPEND="media-libs/tiff
+ openexr? ( media-libs/openexr )"
+
+# compilation of the tiff plugin depends on the check in acinclude.m4.in,
+# which doesn't have a switch.
+
+# ps installed with kghostview, pdf installed with kpdf
+KMEXTRACTONLY="kfile-plugins/ps kfile-plugins/pdf"
+
+src_compile() {
+ local myconf="$myconf $(use_with openexr)"
+ kde-meta_src_compile
+}