summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-01 00:46:19 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-01 00:46:19 +0000
commit56946b772b0caaa50a1d751be0eb9a68a64a21bf (patch)
treed5257eca4133906f77cdbd1b1468aac164f9c33a /kde-base/kdebase-kioslaves
parentBump, fixing bug 239199. This version fixes bug 238942, weirdness w/ portage ... (diff)
downloadgentoo-2-56946b772b0caaa50a1d751be0eb9a68a64a21bf.tar.gz
gentoo-2-56946b772b0caaa50a1d751be0eb9a68a64a21bf.tar.bz2
gentoo-2-56946b772b0caaa50a1d751be0eb9a68a64a21bf.zip
Rev Bumped 3.5.9 and 3.5.10 to fix the ntfs-3g locale mount issue.
Fixes bug 238520 - thanks to Ambroz Bizjak. (Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'kde-base/kdebase-kioslaves')
-rw-r--r--kde-base/kdebase-kioslaves/files/kdebase-3.5.10-ntfs3g-locale.patch78
-rw-r--r--kde-base/kdebase-kioslaves/files/kdebase-3.5.9-ntfs3g-locale.patch31
-rw-r--r--kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.10-r1.ebuild65
-rw-r--r--kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.9-r1.ebuild64
4 files changed, 238 insertions, 0 deletions
diff --git a/kde-base/kdebase-kioslaves/files/kdebase-3.5.10-ntfs3g-locale.patch b/kde-base/kdebase-kioslaves/files/kdebase-3.5.10-ntfs3g-locale.patch
new file mode 100644
index 000000000000..c2f627783ec7
--- /dev/null
+++ b/kde-base/kdebase-kioslaves/files/kdebase-3.5.10-ntfs3g-locale.patch
@@ -0,0 +1,78 @@
+Index: kioslave/media/mediamanager/halbackend.cpp
+===================================================================
+--- kioslave/media/mediamanager/halbackend.cpp (revision 864098)
++++ kioslave/media/mediamanager/halbackend.cpp (working copy)
+@@ -851,13 +851,6 @@
+ result << tmp;
+ }
+
+- if ( valids.contains("locale") )
+- {
+- value = config.readBoolEntry( "locale", true );
+- tmp = QString( "locale=%1" ).arg( value ? "true" : "false" );
+- result << tmp;
+- }
+-
+ if (valids.contains("utf8"))
+ {
+ value = config.readBoolEntry("utf8", true);
+@@ -878,6 +871,15 @@
+ result << "shortname=lower";
+ }
+
++
++ if (valids.contains("locale") && fstype == "ntfs-3g")
++ {
++ char *cType;
++ if ( (cType = getenv("LC_ALL")) || (cType = getenv("LC_CTYPE")) || (cType = getenv("LANG")) ) {
++ result << QString("locale=%1").arg(cType);
++ }
++ }
++
+ if (valids.contains("sync"))
+ {
+ value = config.readBoolEntry("sync", ( valids.contains("flush") && !fstype.endsWith("fat") ) && removable);
+@@ -931,7 +933,7 @@
+
+ QMap<QString,QString> valids = MediaManagerUtils::splitOptions(options);
+
+- const char *names[] = { "ro", "quiet", "atime", "uid", "utf8", "flush", "sync", "locale", 0 };
++ const char *names[] = { "ro", "quiet", "atime", "uid", "utf8", "flush", "sync", 0 };
+ for (int index = 0; names[index]; ++index)
+ if (valids.contains(names[index]))
+ config.writeEntry(names[index], valids[names[index]] == "true");
+@@ -951,10 +953,6 @@
+ config.writeEntry("automount", valids["automount"]);
+ }
+
+- if (valids.contains("locale") ) {
+- config.writeEntry("locale", valids["locale"]);
+- }
+-
+ return true;
+ }
+
+@@ -1153,11 +1151,6 @@
+ soptions << QString("uid=%1").arg(getuid());
+ }
+
+- if (valids["locale"] == "true")
+- {
+- soptions << QString("locale=%1").arg( KGlobal::locale()->language() );
+- }
+-
+ if (valids["ro"] == "true")
+ soptions << "ro";
+
+@@ -1182,6 +1175,11 @@
+ soptions << QString("shortname=%1").arg(valids["shortname"]);
+ }
+
++ if (valids.contains("locale"))
++ {
++ soptions << QString("locale=%1").arg(valids["locale"]);
++ }
++
+ if (valids.contains("journaling"))
+ {
+ QString option = valids["journaling"];
diff --git a/kde-base/kdebase-kioslaves/files/kdebase-3.5.9-ntfs3g-locale.patch b/kde-base/kdebase-kioslaves/files/kdebase-3.5.9-ntfs3g-locale.patch
new file mode 100644
index 000000000000..a5499f15893a
--- /dev/null
+++ b/kde-base/kdebase-kioslaves/files/kdebase-3.5.9-ntfs3g-locale.patch
@@ -0,0 +1,31 @@
+Index: kioslave/media/mediamanager/halbackend.cpp
+===================================================================
+--- kioslave/media/mediamanager/halbackend.cpp (revision 864099)
++++ kioslave/media/mediamanager/halbackend.cpp (working copy)
+@@ -849,6 +849,14 @@
+ result << tmp;
+ }
+
++ if (valids.contains("locale") && fstype == "ntfs-3g")
++ {
++ char *cType;
++ if ( (cType = getenv("LC_ALL")) || (cType = getenv("LC_CTYPE")) || (cType = getenv("LANG")) ) {
++ result << QString("locale=%1").arg(cType);
++ }
++ }
++
+ if (valids.contains("utf8"))
+ {
+ value = config.readBoolEntry("utf8", true);
+@@ -1149,6 +1157,11 @@
+ if (valids["quiet"] == "true")
+ soptions << "quiet";
+
++ if (valids.contains("locale"))
++ {
++ soptions << QString("locale=%1").arg(valids["locale"]);
++ }
++
+ if (valids["utf8"] == "true")
+ soptions << "utf8";
+
diff --git a/kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.10-r1.ebuild b/kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.10-r1.ebuild
new file mode 100644
index 000000000000..08321cdd1ce4
--- /dev/null
+++ b/kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.10-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.10-r1.ebuild,v 1.1 2008/10/01 00:46:18 jmbsvicetto Exp $
+
+KMNAME=kdebase
+KMMODULE=kioslave
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-13.tar.bz2"
+
+DESCRIPTION="kioslave: the kde VFS framework - kioslave plugins present a filesystem-like view of arbitrary data"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="hal kdehiddenvisibility ldap openexr samba"
+
+DEPEND="x11-libs/libXcursor
+ ldap? ( net-nds/openldap )
+ samba? ( >=net-fs/samba-3.0.1 )
+ >=dev-libs/cyrus-sasl-2
+ hal? ( dev-libs/dbus-qt3-old =sys-apps/hal-0.5* )
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ !<kde-base/kdesktop-3.5.6-r1"
+RDEPEND="${DEPEND}
+ virtual/ssh
+ >=kde-base/kdialog-${PV}:${SLOT}" # for the kdeeject script used by the devices/mounthelper ioslave
+DEPEND="${DEPEND}
+ x11-apps/xhost"
+
+# Fixes bug 238520 by applying revision 864963 patch to
+# kdebase/kioslave/media/mediamanager/halbackend.cpp
+PATCHES=( "${FILESDIR}/kdebase-${PV}-ntfs3g-locale.patch" )
+
+# see bug #143375
+KMEXTRA="kdesktop/init"
+
+pkg_setup() {
+ kde_pkg_setup
+ if use hal && has_version '<sys-apps/dbus-0.91' && ! built_with_use sys-apps/dbus qt3; then
+ eerror "To enable HAL support in this package is required to have"
+ eerror "sys-apps/dbus compiled with Qt 3 support."
+ eerror "Please reemerge sys-apps/dbus with USE=\"qt3\"."
+ die "Please reemerge sys-apps/dbus with USE=\"qt3\"."
+ fi
+}
+
+src_unpack() {
+ kde-meta_src_unpack
+ # FIXME - disable broken tests
+ sed -i -e "s:TESTS =.*:TESTS =:" "${S}/kioslave/smtp/Makefile.am" || die "sed failed"
+ sed -i -e "s:TESTS =.*:TESTS =:" "${S}/kioslave/trash/Makefile.am" || die "sed failed"
+
+ if ! [[ $(xhost >> /dev/null 2>/dev/null) ]] ; then
+ einfo "User ${USER} has no X access, disabling some tests."
+ for ioslave in media remote home system ; do
+ sed -e "s:check\: test${ioslave}::" -e "s:./test${ioslave}::" \
+ -i kioslave/${ioslave}/Makefile.am || die "sed failed"
+ done
+ fi
+}
+
+src_compile() {
+ myconf="$myconf $(use_with ldap) $(use_with samba) $(use_with hal) $(use_with openexr)"
+ kde-meta_src_compile
+}
diff --git a/kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.9-r1.ebuild b/kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.9-r1.ebuild
new file mode 100644
index 000000000000..78ce91e5141d
--- /dev/null
+++ b/kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.9-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-kioslaves/kdebase-kioslaves-3.5.9-r1.ebuild,v 1.1 2008/10/01 00:46:18 jmbsvicetto Exp $
+
+KMNAME=kdebase
+KMMODULE=kioslave
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-11.tar.bz2"
+
+DESCRIPTION="kioslave: the kde VFS framework - kioslave plugins present a filesystem-like view of arbitrary data"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="hal kdehiddenvisibility ldap openexr samba"
+
+DEPEND="ldap? ( net-nds/openldap )
+ samba? ( >=net-fs/samba-3.0.1 )
+ >=dev-libs/cyrus-sasl-2
+ hal? ( dev-libs/dbus-qt3-old =sys-apps/hal-0.5* )
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ !<kde-base/kdesktop-3.5.6-r1"
+RDEPEND="${DEPEND}
+ virtual/ssh
+ >=kde-base/kdialog-${PV}:${SLOT}" # for the kdeeject script used by the devices/mounthelper ioslave
+DEPEND="${DEPEND}
+ x11-apps/xhost"
+
+# Fixes bug 238520 by applying revision 864963 patch to
+# kdebase/kioslave/media/mediamanager/halbackend.cpp
+PATCHES=( "${FILESDIR}/kdebase-${PV}-ntfs3g-locale.patch" )
+
+# see bug #143375
+KMEXTRA="kdesktop/init"
+
+pkg_setup() {
+ kde_pkg_setup
+ if use hal && has_version '<sys-apps/dbus-0.91' && ! built_with_use sys-apps/dbus qt3; then
+ eerror "To enable HAL support in this package is required to have"
+ eerror "sys-apps/dbus compiled with Qt 3 support."
+ eerror "Please reemerge sys-apps/dbus with USE=\"qt3\"."
+ die "Please reemerge sys-apps/dbus with USE=\"qt3\"."
+ fi
+}
+
+src_unpack() {
+ kde-meta_src_unpack
+ # FIXME - disable broken tests
+ sed -i -e "s:TESTS =.*:TESTS =:" "${S}/kioslave/smtp/Makefile.am" || die "sed failed"
+ sed -i -e "s:TESTS =.*:TESTS =:" "${S}/kioslave/trash/Makefile.am" || die "sed failed"
+
+ if ! [[ $(xhost >> /dev/null 2>/dev/null) ]] ; then
+ einfo "User ${USER} has no X access, disabling some tests."
+ for ioslave in media remote home system ; do
+ sed -e "s:check\: test${ioslave}::" -e "s:./test${ioslave}::" \
+ -i kioslave/${ioslave}/Makefile.am || die "sed failed"
+ done
+ fi
+}
+
+src_compile() {
+ myconf="$myconf $(use_with ldap) $(use_with samba) $(use_with hal) $(use_with openexr)"
+ kde-meta_src_compile
+}