summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
commitdaec5bb32d717672af35168b16bb8164f2533810 (patch)
tree64932fcb885be528a75e27b8edcfefe4903e17a0 /kde-base/kdebase-data/kdebase-data-4.10.1.ebuild
parentSwitch 9999 to truly live 'develop' branch per user request. (diff)
downloadgentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.gz
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.bz2
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.zip
Bump KDE SC 4.10.1
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 7887F787)
Diffstat (limited to 'kde-base/kdebase-data/kdebase-data-4.10.1.ebuild')
-rw-r--r--kde-base/kdebase-data/kdebase-data-4.10.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kdebase-data/kdebase-data-4.10.1.ebuild b/kde-base/kdebase-data/kdebase-data-4.10.1.ebuild
new file mode 100644
index 000000000000..88e331f9423d
--- /dev/null
+++ b/kde-base/kdebase-data/kdebase-data-4.10.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-data/kdebase-data-4.10.1.ebuild,v 1.1 2013/03/06 13:41:39 dilfridge Exp $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Icons, localization data and various .desktop files from kdebase."
+IUSE="+wallpapers"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ wallpapers? ( $(add_kdebase_dep kde-wallpapers) )
+ $(add_kdebase_dep oxygen-icons)
+ x11-themes/hicolor-icon-theme
+"
+
+KMEXTRA="
+ l10n/
+ localization/
+ pics/
+"
+# Note that the eclass doesn't do this for us, because of KMNOMODULE="true".
+KMEXTRACTONLY="
+ config-runtime.h.cmake
+ kde4
+"
+
+src_configure() {
+ # Remove remnants of hicolor-icon-theme
+ sed -e "s:add_subdirectory[[:space:]]*([[:space:]]*hicolor[[:space:]]*):#donotwant:g" \
+ -i pics/CMakeLists.txt \
+ || die "failed to remove remnants of hicolor-icon-theme"
+
+ kde4-meta_src_configure
+}