summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-05-27 08:56:02 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-05-27 08:56:02 +0000
commitf317807247589afb10ed81b7200d7d85bafa58f0 (patch)
tree4c8282257a5c43d30cf196463f3e3ea2b0aa0429 /kde-base/kdeartwork
parentFix emacs file problem (diff)
downloadgentoo-2-f317807247589afb10ed81b7200d7d85bafa58f0.tar.gz
gentoo-2-f317807247589afb10ed81b7200d7d85bafa58f0.tar.bz2
gentoo-2-f317807247589afb10ed81b7200d7d85bafa58f0.zip
New version.
(Portage version: 2.0.51.19)
Diffstat (limited to 'kde-base/kdeartwork')
-rw-r--r--kde-base/kdeartwork/ChangeLog8
-rw-r--r--kde-base/kdeartwork/files/digest-kdeartwork-3.4.11
-rw-r--r--kde-base/kdeartwork/files/kdeartwork-3.4.1-configure.patch15
-rw-r--r--kde-base/kdeartwork/kdeartwork-3.4.1.ebuild30
4 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/kdeartwork/ChangeLog b/kde-base/kdeartwork/ChangeLog
index a853e163bdba..31b269cb4097 100644
--- a/kde-base/kdeartwork/ChangeLog
+++ b/kde-base/kdeartwork/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeartwork
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/ChangeLog,v 1.119 2005/05/10 21:23:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/ChangeLog,v 1.120 2005/05/27 08:51:57 greg_g Exp $
+
+*kdeartwork-3.4.1 (27 May 2005)
+
+ 27 May 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kdeartwork-3.4.1-configure.patch, +kdeartwork-3.4.1.ebuild:
+ New version. Add patch to fix arts detection (#91696).
10 May 2005; Aron Griffis <agriffis@gentoo.org> kdeartwork-3.4.0.ebuild:
add ~ia64
diff --git a/kde-base/kdeartwork/files/digest-kdeartwork-3.4.1 b/kde-base/kdeartwork/files/digest-kdeartwork-3.4.1
new file mode 100644
index 000000000000..fdf943673e3a
--- /dev/null
+++ b/kde-base/kdeartwork/files/digest-kdeartwork-3.4.1
@@ -0,0 +1 @@
+MD5 0f58245c2fa3c58dbe139da43037a203 kdeartwork-3.4.1.tar.bz2 18066167
diff --git a/kde-base/kdeartwork/files/kdeartwork-3.4.1-configure.patch b/kde-base/kdeartwork/files/kdeartwork-3.4.1-configure.patch
new file mode 100644
index 000000000000..6b86d10bbb66
--- /dev/null
+++ b/kde-base/kdeartwork/files/kdeartwork-3.4.1-configure.patch
@@ -0,0 +1,15 @@
+diff -Nur kdeartwork-3.4.1.orig/kscreensaver/configure.in.in kdeartwork-3.4.1/kscreensaver/configure.in.in
+--- kdeartwork-3.4.1.orig/kscreensaver/configure.in.in 2005-05-23 14:01:05.000000000 +0200
++++ kdeartwork-3.4.1/kscreensaver/configure.in.in 2005-05-25 14:58:51.000000000 +0200
+@@ -32,9 +32,9 @@
+ AC_HAVE_GL( have_gl=yes, have_gl=no )
+
+ AM_CONDITIONAL(COMPILE_GL_XSAVERS, test x$have_gl = xyes)
+-AM_CONDITIONAL(COMPILE_GL_KSAVERS, test x$ac_cv_kde_qt_has_opengl = xyes)
++AM_CONDITIONAL(COMPILE_GL_KSAVERS, test x$have_gl = xyes && test x$ac_cv_kde_qt_has_opengl = xyes)
+ AM_CONDITIONAL(COMPILE_X11_KSAVERS, test "x$ac_x_includes" != x && test "x$ac_x_libraries" != x)
+-AM_CONDITIONAL(COMPILE_ARTS_KSAVERS, test x$have_arts = xyes)
++AM_CONDITIONAL(COMPILE_ARTS_KSAVERS, test x$build_arts = xyes)
+
+ LIBART=
+
diff --git a/kde-base/kdeartwork/kdeartwork-3.4.1.ebuild b/kde-base/kdeartwork/kdeartwork-3.4.1.ebuild
new file mode 100644
index 000000000000..ef11d5477a56
--- /dev/null
+++ b/kde-base/kdeartwork/kdeartwork-3.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/kdeartwork-3.4.1.ebuild,v 1.1 2005/05/27 08:51:57 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE artwork package"
+
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~ia64"
+IUSE="opengl xscreensaver"
+
+DEPEND="~kde-base/kdebase-${PV}
+ opengl? ( virtual/opengl )
+ xscreensaver? ( x11-misc/xscreensaver )"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix compilation with --without-gl and detection of arts.
+ # See kde bug 89387 and 102398.
+ epatch ${FILESDIR}/${P}-configure.patch
+
+ make -f admin/Makefile.common
+}
+
+src_compile() {
+ myconf="--with-dpms $(use_with opengl gl)"
+
+ kde_src_compile
+}