summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-03-21 13:53:30 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-03-21 13:53:30 +0000
commit492743a51daa31b98cdf87657345286dfc6ba646 (patch)
tree3c102841e40d104424f58a058dc4a784838dba16 /kde-base/kde-i18n
parentStable on sparc (diff)
downloadgentoo-2-492743a51daa31b98cdf87657345286dfc6ba646.tar.gz
gentoo-2-492743a51daa31b98cdf87657345286dfc6ba646.tar.bz2
gentoo-2-492743a51daa31b98cdf87657345286dfc6ba646.zip
Better error message if LINGUAS contains unavailable languages (#85997).
(Portage version: 2.0.51.19)
Diffstat (limited to 'kde-base/kde-i18n')
-rw-r--r--kde-base/kde-i18n/ChangeLog6
-rw-r--r--kde-base/kde-i18n/kde-i18n-3.3.2.ebuild20
-rw-r--r--kde-base/kde-i18n/kde-i18n-3.4.0.ebuild20
3 files changed, 29 insertions, 17 deletions
diff --git a/kde-base/kde-i18n/ChangeLog b/kde-base/kde-i18n/ChangeLog
index fc2be40914b0..deee11b64599 100644
--- a/kde-base/kde-i18n/ChangeLog
+++ b/kde-base/kde-i18n/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kde-i18n
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-i18n/ChangeLog,v 1.63 2005/03/20 11:42:56 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-i18n/ChangeLog,v 1.64 2005/03/21 13:53:30 greg_g Exp $
+
+ 21 Mar 2005; Gregorio Guidi <greg_g@gentoo.org> kde-i18n-3.3.2.ebuild,
+ kde-i18n-3.4.0.ebuild:
+ Better error message if LINGUAS contains unavailable languages (#85997).
20 Mar 2005; Marcus D. Hanwell <cryos@gentoo.org> kde-i18n-3.4.0.ebuild:
Marked ~amd64, closes bug 85981.
diff --git a/kde-base/kde-i18n/kde-i18n-3.3.2.ebuild b/kde-base/kde-i18n/kde-i18n-3.3.2.ebuild
index f7c07bc092db..d0dc283f52a7 100644
--- a/kde-base/kde-i18n/kde-i18n-3.3.2.ebuild
+++ b/kde-base/kde-i18n/kde-i18n-3.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-i18n/kde-i18n-3.3.2.ebuild,v 1.11 2005/02/08 17:10:07 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-i18n/kde-i18n-3.3.2.ebuild,v 1.12 2005/03/21 13:53:30 greg_g Exp $
inherit kde eutils
@@ -26,16 +26,20 @@ for X in ${LANGS} ; do
SRC_URI="${SRC_URI} linguas_${X}? ( mirror://kde/stable/${MY_PV}/src/kde-i18n/kde-i18n-${X}-${PV}.tar.bz2 )"
done
-src_unpack() {
- if [ -z "${LINGUAS}" ]; then
- ewarn
- ewarn "You must define a LINGUAS environment variable that contains a list"
- ewarn "of the language codes for which languages you would like to install."
- ewarn "e.g.: LINGUAS=\"se de pt\""
- ewarn
+pkg_setup() {
+ if [ -z "${A}" ]; then
+ echo
+ eerror "You must define a LINGUAS environment variable that contains a list"
+ eerror "of the language codes for which languages you would like to install."
+ eerror "Look at the LANGS variable inside the ebuild to see the list of"
+ eerror "available languages."
+ eerror "e.g.: LINGUAS=\"se de pt\""
+ echo
die
fi
+}
+src_unpack() {
base_src_unpack unpack
cd ${WORKDIR}
use linguas_ru && epatch ${FILESDIR}/kde-i18n-ru-3.3.2-kmplot.diff
diff --git a/kde-base/kde-i18n/kde-i18n-3.4.0.ebuild b/kde-base/kde-i18n/kde-i18n-3.4.0.ebuild
index 6043bbe40873..d55fbad167b4 100644
--- a/kde-base/kde-i18n/kde-i18n-3.4.0.ebuild
+++ b/kde-base/kde-i18n/kde-i18n-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-i18n/kde-i18n-3.4.0.ebuild,v 1.4 2005/03/20 11:42:56 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-i18n/kde-i18n-3.4.0.ebuild,v 1.5 2005/03/21 13:53:30 greg_g Exp $
inherit kde eutils
@@ -23,16 +23,20 @@ for X in ${LANGS} ; do
SRC_URI="${SRC_URI} linguas_${X}? ( mirror://kde/stable/3.4/src/kde-i18n/kde-i18n-${X}-${PV}.tar.bz2 )"
done
-src_unpack() {
- if [ -z "${LINGUAS}" ]; then
- ewarn
- ewarn "You must define a LINGUAS environment variable that contains a list"
- ewarn "of the language codes for which languages you would like to install."
- ewarn "e.g.: LINGUAS=\"se de pt\""
- ewarn
+pkg_setup() {
+ if [ -z "${A}" ]; then
+ echo
+ eerror "You must define a LINGUAS environment variable that contains a list"
+ eerror "of the language codes for which languages you would like to install."
+ eerror "Look at the LANGS variable inside the ebuild to see the list of"
+ eerror "available languages."
+ eerror "e.g.: LINGUAS=\"se de pt\""
+ echo
die
fi
+}
+src_unpack() {
base_src_unpack unpack
if use linguas_ru; then