summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-05-30 11:01:08 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-05-30 11:01:08 +0000
commit777e7a5654e4b315f7dc2afe9ab42b0295432359 (patch)
tree262a627c8822f648d1e6137e38112fbde64c7441 /kde-base/kcontrol
parentVersion bump to install shared libraries. (diff)
downloadgentoo-2-777e7a5654e4b315f7dc2afe9ab42b0295432359.tar.gz
gentoo-2-777e7a5654e4b315f7dc2afe9ab42b0295432359.tar.bz2
gentoo-2-777e7a5654e4b315f7dc2afe9ab42b0295432359.zip
Add patch for gcc-4.4, thanks to Robert Forster
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kcontrol')
-rw-r--r--kde-base/kcontrol/ChangeLog6
-rw-r--r--kde-base/kcontrol/files/kcontrol-3.5.10-gcc44.patch20
-rw-r--r--kde-base/kcontrol/kcontrol-3.5.10.ebuild4
3 files changed, 28 insertions, 2 deletions
diff --git a/kde-base/kcontrol/ChangeLog b/kde-base/kcontrol/ChangeLog
index ec60c3ac2929..9c93d37f78a1 100644
--- a/kde-base/kcontrol/ChangeLog
+++ b/kde-base/kcontrol/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kcontrol
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.143 2009/05/16 09:03:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.144 2009/05/30 11:01:07 tampakrap Exp $
+
+ 30 May 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ kcontrol-3.5.10.ebuild, +files/kcontrol-3.5.10-gcc44.patch:
+ Add patch for gcc-4.4, thanks to Robert Forster
16 May 2009; Robin H. Johnson <robbat2@gentoo.org> kcontrol-3.5.9.ebuild,
kcontrol-3.5.10.ebuild:
diff --git a/kde-base/kcontrol/files/kcontrol-3.5.10-gcc44.patch b/kde-base/kcontrol/files/kcontrol-3.5.10-gcc44.patch
new file mode 100644
index 000000000000..d11a7b91d450
--- /dev/null
+++ b/kde-base/kcontrol/files/kcontrol-3.5.10-gcc44.patch
@@ -0,0 +1,20 @@
+--- branches/KDE/3.5/kdebase/kcontrol/kfontinst/kfontinst/Fontmap.cpp 2005/12/02 23:52:28 485133
++++ branches/KDE/3.5/kdebase/kcontrol/kfontinst/kfontinst/Fontmap.cpp 2009/05/30 00:34:35 975372
+@@ -44,7 +44,7 @@
+
+ using namespace std;
+
+-static char * findSpace(char *str)
++static const char * findSpace(const char *str)
+ {
+ while(str && *str!=' ' && *str!='\t')
+ str++;
+@@ -65,7 +65,7 @@
+ char a[constMaxLen+1],
+ b[constFileMaxLen+1];
+
+- char *slash1=strchr(line, '/'),
++ const char *slash1=strchr(line, '/'),
+ *space1=slash1 ? findSpace(slash1) : NULL, //strchr(slash1, ' ') : NULL,
+ *ob=slash1 ? strchr(slash1, '(') : NULL,
+ *cb=ob ? strchr(ob, ')') : NULL,
diff --git a/kde-base/kcontrol/kcontrol-3.5.10.ebuild b/kde-base/kcontrol/kcontrol-3.5.10.ebuild
index c75b978e5a2b..80fb05f45747 100644
--- a/kde-base/kcontrol/kcontrol-3.5.10.ebuild
+++ b/kde-base/kcontrol/kcontrol-3.5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/kcontrol-3.5.10.ebuild,v 1.2 2009/05/16 09:03:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/kcontrol-3.5.10.ebuild,v 1.3 2009/05/30 11:01:07 tampakrap Exp $
KMNAME=kdebase
EAPI="1"
@@ -49,6 +49,8 @@ KMCOPYLIB="libkonq libkonq
libtaskbar kicker/taskbar
libtaskmanager kicker/taskmanager"
+PATCHES=( "${FILESDIR}/${P}-gcc44.patch" )
+
src_unpack() {
kde-meta_src_unpack unpack