summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
committerChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
commitb5c71598bd396d68feb09813aad0c75a45f81a3a (patch)
treeb738e19f08caad8c28f1ee6bee7051613495e2de /kde-base/kate
parentFix docs installation, bug 487448 by Juergen Rose. Add -fno-strict-aliasing t... (diff)
downloadgentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.gz
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.bz2
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.zip
Version bump KDE SC 4.11.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.11.2.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index ed8556254d9a..f01f4dd36d60 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.301 2013/09/05 18:44:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.302 2013/10/09 23:04:25 creffett Exp $
+
+*kate-4.11.2 (08 Oct 2013)
+
+ 08 Oct 2013; Chris Reffett <creffett@gentoo.org> +kate-4.11.2.ebuild:
+ Version bump KDE SC 4.11.2
05 Sep 2013; Michał Górny <mgorny@gentoo.org> kate-4.10.5.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/kde-base/kate/kate-4.11.2.ebuild b/kde-base/kate/kate-4.11.2.ebuild
new file mode 100644
index 000000000000..5f09a0a662d5
--- /dev/null
+++ b/kde-base/kate/kate-4.11.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.11.2.ebuild,v 1.1 2013/10/09 23:04:25 creffett Exp $
+
+EAPI=5
+KDE_HANDBOOK="optional"
+KMNAME="kate"
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit python-single-r1 kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+HOMEPAGE="http://www.kde.org/applications/utilities/kate http://kate-editor.org"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ $(add_kdebase_dep kactivities)
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/qjson
+ python? (
+ ${PYTHON_DEPS}
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}" 4.9.2-r1)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep katepart)
+"
+
+KMEXTRA="
+ addons/kate
+ addons/plasma
+"
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build python pate)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}