summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
commita4c1d03d518d1416c826bb73ad524dc9bf1702a5 (patch)
treed6a50377f609e5e7550ca8a99686adcdcbdbd7a1 /kde-base/kate
parentRemoved unneccessary python_copy_sources (diff)
downloadgentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.gz
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.bz2
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.zip
[kde-base] Add KDE SC 4.6.1
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.6.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 2ebc00f1f8b5..20cd606a8333 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.189 2011/01/26 20:28:58 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.190 2011/03/04 17:59:58 alexxy Exp $
+
+*kate-4.6.1 (04 Mar 2011)
+
+ 04 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> +kate-4.6.1.ebuild:
+ Version bump KDE SC 4.6.1
*kate-4.6.0 (26 Jan 2011)
diff --git a/kde-base/kate/kate-4.6.1.ebuild b/kde-base/kate/kate-4.6.1.ebuild
new file mode 100644
index 000000000000..d28cbf283d3b
--- /dev/null
+++ b/kde-base/kate/kate-4.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.6.1.ebuild,v 1.1 2011/03/04 17:59:58 alexxy Exp $
+
+EAPI=3
+
+KDE_HANDBOOK="optional"
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}