summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
committerJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
commitc9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f (patch)
tree94015d5f29e37019f20bdced917f52e9b11645da /kde-base/kalzium
parentAdd kde-workspace 4.11.11 SRC_URI, remove obsolete. (diff)
downloadgentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.gz
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.bz2
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.zip
Version bump KDE SC 4.13.3
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.13.3.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 723f7da4f904..81ff072e3815 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.330 2014/06/19 13:32:05 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.331 2014/07/16 17:41:03 johu Exp $
+
+*kalzium-4.13.3 (16 Jul 2014)
+
+ 16 Jul 2014; Johannes Huber <johu@gentoo.org> +kalzium-4.13.3.ebuild:
+ Version bump KDE SC 4.13.3
19 Jun 2014; Chris Reffett <creffett@gentoo.org> -kalzium-4.13.1.ebuild:
Remove KDE SC 4.13.1
diff --git a/kde-base/kalzium/kalzium-4.13.3.ebuild b/kde-base/kalzium/kalzium-4.13.3.ebuild
new file mode 100644
index 000000000000..002827e884c5
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.13.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.13.3.ebuild,v 1.1 2014/07/16 17:41:03 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements."
+HOMEPAGE="http://www.kde.org/applications/education/kalzium
+http://edu.kde.org/kalzium"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +plasma solver"
+
+DEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? (
+ >=dev-cpp/eigen-2.0.3:2
+ sci-chemistry/avogadro
+ >=sci-chemistry/openbabel-2.2
+ )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND=${DEPEND}
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ local mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor Avogadro)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}