summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-03 23:52:52 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-03 23:52:52 +0000
commit2d30338c62fffc221098aa2a546422b95f8cd148 (patch)
tree31af22c22d3f52e37b7c29e9581e2a2193768b2c /kde-base/kalzium
parentVersion bump KDE 4.3.0 (diff)
downloadgentoo-2-2d30338c62fffc221098aa2a546422b95f8cd148.tar.gz
gentoo-2-2d30338c62fffc221098aa2a546422b95f8cd148.tar.bz2
gentoo-2-2d30338c62fffc221098aa2a546422b95f8cd148.zip
Version bump KDE 4.3.0
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.3.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 7a03c4f26c89..417c5a5dad26 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.133 2009/07/12 11:39:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.134 2009/08/03 23:52:52 wired Exp $
+
+*kalzium-4.3.0 (03 Aug 2009)
+
+ 03 Aug 2009; Alex Alexander <wired@gentoo.org> +kalzium-4.3.0.ebuild:
+ Version bump
12 Jul 2009; Raúl Porcel <armin76@gentoo.org> kalzium-3.5.10.ebuild:
alpha/ia64/sparc stable wrt #271889
diff --git a/kde-base/kalzium/kalzium-4.3.0.ebuild b/kde-base/kalzium/kalzium-4.3.0.ebuild
new file mode 100644
index 000000000000..dc355fa711cc
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.3.0.ebuild,v 1.1 2009/08/03 23:52:52 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="editor debug +handbook +plasma solver"
+
+COMMON_DEPEND="
+ >=kde-base/libkdeedu-${PV}:${SLOT}[kdeprefix=]
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${COMMON_DEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ kde4-meta_src_configure
+}