summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
commit318092ea225b3d6ad7192e8ae024a631e482b266 (patch)
tree91df8808be8c8389bc73293ff837135ae83c78e3 /kde-base/dolphin
parentUpdate init file /var/run/apcupsd directory > /run/apcupsd (diff)
downloadgentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.gz
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.bz2
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.zip
Version bump KDE SC 4.11.4
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.11.4.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 075a322527da..8f89016215bb 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.209 2013/11/09 13:43:52 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.210 2013/12/03 22:36:00 johu Exp $
+
+*dolphin-4.11.4 (03 Dec 2013)
+
+ 03 Dec 2013; Johannes Huber <johu@gentoo.org> +dolphin-4.11.4.ebuild:
+ Version bump KDE SC 4.11.4
*dolphin-4.11.3-r1 (09 Nov 2013)
diff --git a/kde-base/dolphin/dolphin-4.11.4.ebuild b/kde-base/dolphin/dolphin-4.11.4.ebuild
new file mode 100644
index 000000000000..0b2362802579
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.11.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.11.4.ebuild,v 1.1 2013/12/03 22:36:00 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+HOMEPAGE="http://dolphin.kde.org http://www.kde.org/applications/system/dolphin"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ x11-libs/libXrender
+ semantic-desktop? (
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ dev-libs/soprano
+ $(add_kdebase_dep nepomuk-core)
+ $(add_kdebase_dep nepomuk-widgets)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+RESTRICT="test"
+# bug 393129
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop NepomukCore)
+ $(cmake-utils_use_with semantic-desktop NepomukWidgets)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version media-gfx/icoutils ; then
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ fi
+}