summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-08-20 16:02:53 +0000
committerJohannes Huber <johu@gentoo.org>2014-08-20 16:02:53 +0000
commitb5a8b2e1508f119b3da9007782069d7554f7973d (patch)
tree3039b14e2a5b6b94c65ead7c9d1b9e21cdab1b44 /kde-base/analitza
parentStable for x86, wrt bug #520220 (diff)
downloadgentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.tar.gz
gentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.tar.bz2
gentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.zip
Version bump KDE SC 4.14.0
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/analitza')
-rw-r--r--kde-base/analitza/ChangeLog7
-rw-r--r--kde-base/analitza/analitza-4.14.0.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/kde-base/analitza/ChangeLog b/kde-base/analitza/ChangeLog
index a02ea36d3bf8..34b15838a660 100644
--- a/kde-base/analitza/ChangeLog
+++ b/kde-base/analitza/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/analitza
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/analitza/ChangeLog,v 1.119 2014/07/23 16:53:12 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/analitza/ChangeLog,v 1.120 2014/08/20 16:02:40 johu Exp $
+
+*analitza-4.14.0 (20 Aug 2014)
+
+ 20 Aug 2014; Johannes Huber <johu@gentoo.org> +analitza-4.14.0.ebuild:
+ Version bump KDE SC 4.14.0
23 Jul 2014; Johannes Huber <johu@gentoo.org> -analitza-4.13.2.ebuild:
Remove KDE SC 4.13.2
diff --git a/kde-base/analitza/analitza-4.14.0.ebuild b/kde-base/analitza/analitza-4.14.0.ebuild
new file mode 100644
index 000000000000..df77d85daee8
--- /dev/null
+++ b/kde-base/analitza/analitza-4.14.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/analitza/analitza-4.14.0.ebuild,v 1.1 2014/08/20 16:02:40 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="never"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE library for mathematical features"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug readline"
+
+DEPEND="
+ opengl? ( virtual/glu )
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with readline)
+ )
+
+ kde4-base_src_configure
+}