summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 04:00:18 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 04:00:18 +0000
commitede46bfeb0ade603024fd1182b04674851cd5fa3 (patch)
tree4afa2f7a38c5bd7d6c91448e6789f315884e8f1b /gnustep-libs
parentKeyworded ppc for GNOME 2.8 (Manifest recommit) (diff)
downloadgentoo-2-ede46bfeb0ade603024fd1182b04674851cd5fa3.tar.gz
gentoo-2-ede46bfeb0ade603024fd1182b04674851cd5fa3.tar.bz2
gentoo-2-ede46bfeb0ade603024fd1182b04674851cd5fa3.zip
Mass Update: gnustep.eclass revamped to allow configurable root install; gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions bumped where files would change); some KEYWORDS were accidentally dropped between version bumps of packages -- this has been resolved; windowmaker correctly supports gnustep now; gnustep-funcs.eclass added -- used where info on an installed gnustep-env is needed rather than making a full GNUstep application
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/camaelon/ChangeLog12
-rw-r--r--gnustep-libs/camaelon/camaelon-0.1-r1.ebuild22
-rw-r--r--gnustep-libs/camaelon/camaelon-0.1.ebuild4
-rw-r--r--gnustep-libs/camaelon/files/config-camaelon.sh4
-rw-r--r--gnustep-libs/camaelon/files/digest-camaelon-0.1-r11
-rw-r--r--gnustep-libs/imagekits/ChangeLog9
-rw-r--r--gnustep-libs/imagekits/imagekits-0.6.ebuild4
-rw-r--r--gnustep-libs/renaissance/ChangeLog11
-rw-r--r--gnustep-libs/renaissance/files/digest-renaissance-0.7.01
-rw-r--r--gnustep-libs/renaissance/renaissance-0.7.0.ebuild21
-rw-r--r--gnustep-libs/renaissance/renaissance-0.8.0.ebuild10
-rw-r--r--gnustep-libs/renaissance/renaissance-0.8.1_pre20040927.ebuild14
-rw-r--r--gnustep-libs/steptalk/ChangeLog10
-rw-r--r--gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild12
14 files changed, 90 insertions, 45 deletions
diff --git a/gnustep-libs/camaelon/ChangeLog b/gnustep-libs/camaelon/ChangeLog
index 0cb84b36b013..db40f69083fc 100644
--- a/gnustep-libs/camaelon/ChangeLog
+++ b/gnustep-libs/camaelon/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for gnustep-libs/camaelon
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/camaelon/ChangeLog,v 1.5 2004/11/05 22:11:24 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/camaelon/ChangeLog,v 1.6 2004/11/12 03:57:54 fafhrd Exp $
+
+*camaelon-0.1-r1 (11 Nov 2004)
+
+ 11 Nov 2004; Armando Di Cianno <fafhrd@gentoo.org> files/config-camaelon.sh,
+ +camaelon-0.1-r1.ebuild, camaelon-0.1.ebuild:
+ Mass Update: gnustep.eclass revamped to allow configurable root install;
+ gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions
+ bumped where files would change); some KEYWORDS were accidentally dropped
+ between version bumps of packages -- this has been resolved; windowmaker
+ correctly supports gnustep now
05 Nov 2004; Simon Stelling <blubb@gentoo.org> camaelon-0.1.ebuild:
added ~amd64
diff --git a/gnustep-libs/camaelon/camaelon-0.1-r1.ebuild b/gnustep-libs/camaelon/camaelon-0.1-r1.ebuild
new file mode 100644
index 000000000000..d869e39d28d3
--- /dev/null
+++ b/gnustep-libs/camaelon/camaelon-0.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/camaelon/camaelon-0.1-r1.ebuild,v 1.1 2004/11/12 03:57:54 fafhrd Exp $
+
+inherit gnustep
+
+S=${WORKDIR}/${PN/c/C}
+
+DESCRIPTION="Camaelon allows you to load theme bundles for GNUstep."
+
+HOMEPAGE="http://www.roard.com/camaelon/"
+SRC_URI="http://www.roard.com/camaelon/download/${P/c/C}.tgz"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="${IUSE}"
+DEPEND="${GS_DEPEND}"
+RDEPEND="${GS_RDEPEND}"
+
+egnustep_install_domain "Local"
+
diff --git a/gnustep-libs/camaelon/camaelon-0.1.ebuild b/gnustep-libs/camaelon/camaelon-0.1.ebuild
index 0be0af04a571..b1027a3b1236 100644
--- a/gnustep-libs/camaelon/camaelon-0.1.ebuild
+++ b/gnustep-libs/camaelon/camaelon-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/camaelon/camaelon-0.1.ebuild,v 1.5 2004/11/05 22:11:24 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/camaelon/camaelon-0.1.ebuild,v 1.6 2004/11/12 03:57:54 fafhrd Exp $
inherit gnustep
@@ -18,3 +18,5 @@ IUSE="${IUSE}"
DEPEND="${GS_DEPEND}"
RDEPEND="${GS_RDEPEND}"
+egnustep_install_domain "System"
+
diff --git a/gnustep-libs/camaelon/files/config-camaelon.sh b/gnustep-libs/camaelon/files/config-camaelon.sh
index 6636748ecfdd..0300ad754327 100644
--- a/gnustep-libs/camaelon/files/config-camaelon.sh
+++ b/gnustep-libs/camaelon/files/config-camaelon.sh
@@ -1,4 +1,4 @@
echo "Applying Camaelon default theme..."
-echo "defaults write NSGlobalDomain GUIThemeBundles \"${GNUSTEP_SYSTEM_ROOT}/Library/Bundles/Camaelon.themeEngine\""
-defaults write NSGlobalDomain GUIThemeBundles "${GNUSTEP_SYSTEM_ROOT}/Library/Bundles/Camaelon.themeEngine"
+echo "defaults write NSGlobalDomain GSAppKitUserBundles \"(${GNUSTEP_LOCAL_ROOT}/Library/Bundles/Camaelon.themeEngine)\""
+defaults write NSGlobalDomain GSAppKitUserBundles "(${GNUSTEP_LOCAL_ROOT}/Library/Bundles/Camaelon.themeEngine)"
diff --git a/gnustep-libs/camaelon/files/digest-camaelon-0.1-r1 b/gnustep-libs/camaelon/files/digest-camaelon-0.1-r1
new file mode 100644
index 000000000000..beb8fb05c375
--- /dev/null
+++ b/gnustep-libs/camaelon/files/digest-camaelon-0.1-r1
@@ -0,0 +1 @@
+MD5 5b870e8e8d543ac25e58a231ab86bb57 Camaelon-0.1.tgz 50170
diff --git a/gnustep-libs/imagekits/ChangeLog b/gnustep-libs/imagekits/ChangeLog
index 5211072b64b5..51ca9820a15c 100644
--- a/gnustep-libs/imagekits/ChangeLog
+++ b/gnustep-libs/imagekits/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnustep-libs/imagekits
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/imagekits/ChangeLog,v 1.2 2004/10/09 22:19:00 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/imagekits/ChangeLog,v 1.3 2004/11/12 03:58:10 fafhrd Exp $
+
+ 11 Nov 2004; Armando Di Cianno <fafhrd@gentoo.org> imagekits-0.6.ebuild:
+ Mass Update: gnustep.eclass revamped to allow configurable root install;
+ gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions
+ bumped where files would change); some KEYWORDS were accidentally dropped
+ between version bumps of packages -- this has been resolved; windowmaker
+ correctly supports gnustep now
*imagekits-0.6 (10 Oct 2004)
diff --git a/gnustep-libs/imagekits/imagekits-0.6.ebuild b/gnustep-libs/imagekits/imagekits-0.6.ebuild
index 679217750079..9eb68e0a68ee 100644
--- a/gnustep-libs/imagekits/imagekits-0.6.ebuild
+++ b/gnustep-libs/imagekits/imagekits-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/imagekits/imagekits-0.6.ebuild,v 1.2 2004/10/09 22:19:00 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/imagekits/imagekits-0.6.ebuild,v 1.3 2004/11/12 03:58:10 fafhrd Exp $
inherit gnustep
@@ -17,3 +17,5 @@ IUSE="${IUSE}"
DEPEND="${GS_DEPEND}"
RDEPEND="${GS_RDEPEND}"
+egnustep_install_domain "System"
+
diff --git a/gnustep-libs/renaissance/ChangeLog b/gnustep-libs/renaissance/ChangeLog
index 35a34665f5e9..a89fd8011a0a 100644
--- a/gnustep-libs/renaissance/ChangeLog
+++ b/gnustep-libs/renaissance/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnustep-libs/renaissance
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/ChangeLog,v 1.6 2004/10/17 10:02:19 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/ChangeLog,v 1.7 2004/11/12 03:58:29 fafhrd Exp $
+
+ 11 Nov 2004; Armando Di Cianno <fafhrd@gentoo.org>
+ -renaissance-0.7.0.ebuild, renaissance-0.8.0.ebuild,
+ renaissance-0.8.1_pre20040927.ebuild:
+ Mass Update: gnustep.eclass revamped to allow configurable root install;
+ gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions
+ bumped where files would change); some KEYWORDS were accidentally dropped
+ between version bumps of packages -- this has been resolved; windowmaker
+ correctly supports gnustep now
17 Oct 2004; David Holm <dholm@gentoo.org>
renaissance-0.8.1_pre20040927.ebuild:
diff --git a/gnustep-libs/renaissance/files/digest-renaissance-0.7.0 b/gnustep-libs/renaissance/files/digest-renaissance-0.7.0
deleted file mode 100644
index 11b81be6a899..000000000000
--- a/gnustep-libs/renaissance/files/digest-renaissance-0.7.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e9ff8c15473dda40ad199c7c30e0d6c3 Renaissance-0.7.0.tar.gz 264580
diff --git a/gnustep-libs/renaissance/renaissance-0.7.0.ebuild b/gnustep-libs/renaissance/renaissance-0.7.0.ebuild
deleted file mode 100644
index 139eb85869eb..000000000000
--- a/gnustep-libs/renaissance/renaissance-0.7.0.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/renaissance-0.7.0.ebuild,v 1.2 2004/07/23 15:01:54 fafhrd Exp $
-
-inherit gnustep-old
-
-S=${WORKDIR}/${P/r/R}
-
-DESCRIPTION="GNUstep xml-based UI toolkit"
-HOMEPAGE="http://www.gnustep.org"
-SRC_URI="http://www.gnustep.it/Renaissance/Download/${P/r/R}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="x86 ~ppc"
-DEPEND=">=gnustep-base/gnustep-gui-0.8.5"
-IUSE=""
-
-src_compile() {
- addwrite ~/GNUstep/Library/Services/.GNUstepAppList
- egnustepmake
-}
diff --git a/gnustep-libs/renaissance/renaissance-0.8.0.ebuild b/gnustep-libs/renaissance/renaissance-0.8.0.ebuild
index c3cb24a49870..3017a18d2c96 100644
--- a/gnustep-libs/renaissance/renaissance-0.8.0.ebuild
+++ b/gnustep-libs/renaissance/renaissance-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/renaissance-0.8.0.ebuild,v 1.2 2004/10/21 19:09:54 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/renaissance-0.8.0.ebuild,v 1.3 2004/11/12 03:58:29 fafhrd Exp $
inherit gnustep
@@ -18,6 +18,8 @@ IUSE="${IUSE} doc"
DEPEND="${GS_DEPEND}"
RDEPEND="${GS_RDEPEND}"
+egnustep_install_domain "System"
+
src_install() {
cd ${S}
egnustep_env
@@ -28,9 +30,9 @@ src_install() {
egnustep_make
egnustep_install
mkdir -p ${TMP}/tmpdocs
- mv ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/* ${TMP}/tmpdocs
- mkdir -p ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/Renaissance
- mv ${TMP}/tmpdocs/* ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/Renaissance
+ mv ${D}$(egnustep_install_domain)/Library/Documentation/* ${TMP}/tmpdocs
+ mkdir -p ${D}$(egnustep_install_domain)/Library/Documentation/Developer/Renaissance
+ mv ${TMP}/tmpdocs/* ${D}$(egnustep_install_domain)/Library/Documentation/Developer/Renaissance
cd ..
fi
egnustep_package_config
diff --git a/gnustep-libs/renaissance/renaissance-0.8.1_pre20040927.ebuild b/gnustep-libs/renaissance/renaissance-0.8.1_pre20040927.ebuild
index 6cb6ea077cb7..25fa0632cda5 100644
--- a/gnustep-libs/renaissance/renaissance-0.8.1_pre20040927.ebuild
+++ b/gnustep-libs/renaissance/renaissance-0.8.1_pre20040927.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/renaissance-0.8.1_pre20040927.ebuild,v 1.3 2004/10/21 19:09:54 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/renaissance-0.8.1_pre20040927.ebuild,v 1.4 2004/11/12 03:58:29 fafhrd Exp $
ECVS_CVS_COMMAND="cvs -q"
ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
ECVS_USER="anoncvs"
ECVS_AUTH="ext"
ECVS_MODULE="gnustep/dev-libs/${PN/r/R}"
-ECVS_CO_OPTS="-D ${PV/*_pre}"
-ECVS_UP_OPTS="-D ${PV/*_pre}"
+ECVS_CO_OPTS="-P -D ${PV/*_pre}"
+ECVS_UP_OPTS="-dP -D ${PV/*_pre}"
ECVS_TOP_DIR="${DISTDIR}/cvs-src/savannah.gnu.org-gnustep"
inherit gnustep cvs
@@ -25,6 +25,8 @@ IUSE="${IUSE} doc"
DEPEND="${GS_DEPEND}"
RDEPEND="${GS_RDEPEND}"
+egnustep_install_domain "System"
+
src_install() {
cd ${S}
egnustep_env
@@ -35,9 +37,9 @@ src_install() {
egnustep_make
egnustep_install
mkdir -p ${TMP}/tmpdocs
- mv ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/* ${TMP}/tmpdocs
- mkdir -p ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/Renaissance
- mv ${TMP}/tmpdocs/* ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/Renaissance
+ mv ${D}$(egnustep_install_domain)/Library/Documentation/* ${TMP}/tmpdocs
+ mkdir -p ${D}$(egnustep_install_domain)/Library/Documentation/Developer/Renaissance
+ mv ${TMP}/tmpdocs/* ${D}$(egnustep_install_domain)/Library/Documentation/Developer/Renaissance
cd ..
fi
egnustep_package_config
diff --git a/gnustep-libs/steptalk/ChangeLog b/gnustep-libs/steptalk/ChangeLog
index cba531be69b7..a7ab0d29a444 100644
--- a/gnustep-libs/steptalk/ChangeLog
+++ b/gnustep-libs/steptalk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnustep-libs/steptalk
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/steptalk/ChangeLog,v 1.2 2004/10/18 12:13:11 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/steptalk/ChangeLog,v 1.3 2004/11/12 03:56:25 fafhrd Exp $
+
+ 11 Nov 2004; Armando Di Cianno <fafhrd@gentoo.org>
+ steptalk-0.8.3_pre20040927.ebuild:
+ Mass Update: gnustep.eclass revamped to allow configurable root install;
+ gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions
+ bumped where files would change); some KEYWORDS were accidentally dropped
+ between version bumps of packages -- this has been resolved; windowmaker
+ correctly supports gnustep now
18 Oct 2004; David Holm <dholm@gentoo.org>
steptalk-0.8.3_pre20040927.ebuild:
diff --git a/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild b/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild
index 5552f03da448..de53f479778b 100644
--- a/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild
+++ b/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild,v 1.3 2004/10/21 19:10:16 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild,v 1.4 2004/11/12 03:56:25 fafhrd Exp $
ECVS_CVS_COMMAND="cvs -q"
ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
ECVS_USER="anoncvs"
ECVS_AUTH="ext"
ECVS_MODULE="gnustep/dev-libs/${PN/stept/StepT}"
-ECVS_CO_OPTS="-D ${PV/*_pre}"
-ECVS_UP_OPTS="-D ${PV/*_pre}"
+ECVS_CO_OPTS="-P -D ${PV/*_pre}"
+ECVS_UP_OPTS="-dP -D ${PV/*_pre}"
ECVS_TOP_DIR="${DISTDIR}/cvs-src/savannah.gnu.org-gnustep"
inherit gnustep cvs
@@ -25,6 +25,8 @@ IUSE="${IUSE} doc"
DEPEND="${GS_DEPEND}"
RDEPEND="${GS_RDEPEND}"
+egnustep_install_domain "System"
+
src_install() {
cd ${S}
egnustep_env
@@ -36,8 +38,8 @@ src_install() {
mkdir -p ${TMP}/tmpdocs
mv *.* ${TMP}/tmpdocs
mv Reference ${TMP}/tmpdocs
- mkdir -p ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/${PN/stept/StepT}
- mv ${TMP}/tmpdocs/* ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/${PN/stept/StepT}
+ mkdir -p ${D}$(egnustep_install_domain)/Library/Documentation/Developer/${PN/stept/StepT}
+ mv ${TMP}/tmpdocs/* ${D}$(egnustep_install_domain)/Library/Documentation/Developer/${PN/stept/StepT}
cd ..
fi
egnustep_package_config