summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-04-20 15:28:29 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-04-20 15:28:29 +0000
commit110b2a742ba7d2bbb11889aa6a986fe94da3c6e7 (patch)
tree838e34b356ece15582e9c8ce6db36103524d20cf /gnustep-libs
parentfix build after the big libav* version bump, backported by Luca Barbato, bug ... (diff)
downloadgentoo-2-110b2a742ba7d2bbb11889aa6a986fe94da3c6e7.tar.gz
gentoo-2-110b2a742ba7d2bbb11889aa6a986fe94da3c6e7.tar.bz2
gentoo-2-110b2a742ba7d2bbb11889aa6a986fe94da3c6e7.zip
Fix compilation (use of bool keyword as variable name)
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/cddb/ChangeLog6
-rw-r--r--gnustep-libs/cddb/cddb-0.2.ebuild3
-rw-r--r--gnustep-libs/cddb/files/cddb-0.2-bool.patch57
3 files changed, 64 insertions, 2 deletions
diff --git a/gnustep-libs/cddb/ChangeLog b/gnustep-libs/cddb/ChangeLog
index 33b3cedb03d1..12f7c263a5a5 100644
--- a/gnustep-libs/cddb/ChangeLog
+++ b/gnustep-libs/cddb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnustep-libs/cddb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/cddb/ChangeLog,v 1.3 2011/04/10 18:21:07 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/cddb/ChangeLog,v 1.4 2011/04/20 15:28:29 voyageur Exp $
+
+ 20 Apr 2011; Bernard Cafarelli <voyageur@gentoo.org> cddb-0.2.ebuild,
+ +files/cddb-0.2-bool.patch:
+ Fix compilation (use of bool keyword as variable name)
10 Apr 2011; Christian Faulhammer <fauli@gentoo.org> cddb-0.2.ebuild:
stable x86, bug 356967
diff --git a/gnustep-libs/cddb/cddb-0.2.ebuild b/gnustep-libs/cddb/cddb-0.2.ebuild
index 30f70b1f4b9a..dfd28ff6acdc 100644
--- a/gnustep-libs/cddb/cddb-0.2.ebuild
+++ b/gnustep-libs/cddb/cddb-0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/cddb/cddb-0.2.ebuild,v 1.3 2011/04/10 18:21:07 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/cddb/cddb-0.2.ebuild,v 1.4 2011/04/20 15:28:29 voyageur Exp $
inherit gnustep-2
@@ -20,4 +20,5 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-gnustep-make-2.patch
+ epatch "${FILESDIR}"/${P}-bool.patch
}
diff --git a/gnustep-libs/cddb/files/cddb-0.2-bool.patch b/gnustep-libs/cddb/files/cddb-0.2-bool.patch
new file mode 100644
index 000000000000..4b3407f789e5
--- /dev/null
+++ b/gnustep-libs/cddb/files/cddb-0.2-bool.patch
@@ -0,0 +1,57 @@
+diff -Naur cddb.bundle.orig/Cddb/Cddb.h cddb.bundle/Cddb/Cddb.h
+--- cddb.bundle.orig/Cddb/Cddb.h 2002-10-15 16:32:13.000000000 +0200
++++ cddb.bundle/Cddb/Cddb.h 2011-04-20 17:13:48.209532185 +0200
+@@ -54,8 +54,7 @@
+ * The number of object in NSArray are the number of tracks.
+ * The keys of NSDictionary are "length" and "offset".
+ */
+-- (NSString *) discidWithCDTracks: (NSArray *) tracks
+- locally: (BOOL) bool;
++- (NSString *) discidWithCDTracks: (NSArray *) tracks locally: (BOOL) boolean;
+
+ /* Return the query using a NSArray of NSDictionary.
+ * The number of object in NSArray are the number of tracks.
+@@ -75,9 +74,7 @@
+ * NSString, "extdata" (extra data about this album)
+ * NSArray, "exttitles" (extra-title of each track)
+ */
+-- (NSDictionary *) readWithCategory: (NSString *) category
+- discid: (NSString *) discid
+- postProcess: (BOOL) bool;
++- (NSDictionary *) readWithCategory: (NSString *) category discid: (NSString *) discid postProcess: (BOOL) boolean;
+
+ /* Low-level methods */
+ /* Input format:
+diff -Naur cddb.bundle.orig/Cddb/Cddb.m cddb.bundle/Cddb/Cddb.m
+--- cddb.bundle.orig/Cddb/Cddb.m 2002-10-17 15:17:01.000000000 +0200
++++ cddb.bundle/Cddb/Cddb.m 2011-04-20 17:14:08.737891180 +0200
+@@ -44,7 +44,7 @@
+
+
+ - (NSString *) discidWithCDTracks: (NSArray *) tracks
+- locally: (BOOL) bool
++ locally: (BOOL) boolean
+ {
+ NSMutableString *string = [NSMutableString new];
+ int i = 0, numtracks = 0;
+@@ -72,7 +72,7 @@
+
+ [string appendFormat: @" %d", totaltime];
+
+- if (bool == YES) // Calculate locally
++ if (boolean == YES) // Calculate locally
+ {
+ RELEASE(string);
+ RELEASE(tracks);
+@@ -123,9 +123,9 @@
+
+ - (NSDictionary *) readWithCategory: (NSString *) category
+ discid: (NSString *) discid
+- postProcess: (BOOL) bool
++ postProcess: (BOOL) boolean
+ {
+- if (bool == NO)
++ if (boolean == NO)
+ return [self read: [NSString stringWithFormat: @"%@ %@", category, discid]];
+ else
+ {