summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-08-04 09:47:24 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-08-04 09:47:24 +0000
commit79cd5f5d835056e2650b97d6ffe8f4eab13ac255 (patch)
treee7acd5df10aa7ef397b1b8109bbab97d5f114408 /gnustep-base
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-79cd5f5d835056e2650b97d6ffe8f4eab13ac255.tar.gz
gentoo-2-79cd5f5d835056e2650b97d6ffe8f4eab13ac255.tar.bz2
gentoo-2-79cd5f5d835056e2650b97d6ffe8f4eab13ac255.zip
Version bump, add tracing API, bugfixes
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/libobjc2/ChangeLog7
-rw-r--r--gnustep-base/libobjc2/libobjc2-1.8.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/gnustep-base/libobjc2/ChangeLog b/gnustep-base/libobjc2/ChangeLog
index b4e0615c3ec2..443134a140b0 100644
--- a/gnustep-base/libobjc2/ChangeLog
+++ b/gnustep-base/libobjc2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-base/libobjc2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.14 2015/05/20 11:27:34 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.15 2015/08/04 09:47:24 voyageur Exp $
+
+*libobjc2-1.8 (04 Aug 2015)
+
+ 04 Aug 2015; Bernard Cafarelli <voyageur@gentoo.org> +libobjc2-1.8.ebuild:
+ Version bump, add tracing API, bugfixes
*libobjc2-1.7-r1 (20 May 2015)
diff --git a/gnustep-base/libobjc2/libobjc2-1.8.ebuild b/gnustep-base/libobjc2/libobjc2-1.8.ebuild
new file mode 100644
index 000000000000..c50fe5cb9a1a
--- /dev/null
+++ b/gnustep-base/libobjc2/libobjc2-1.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.8.ebuild,v 1.1 2015/08/04 09:47:24 voyageur Exp $
+
+EAPI=5
+inherit cmake-utils eutils
+
+DESCRIPTION="GNUstep Objective-C runtime"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="https://github.com/gnustep/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boehm-gc cxx test"
+
+RDEPEND="boehm-gc? ( dev-libs/boehm-gc )
+ cxx? ( sys-libs/libcxx )"
+DEPEND="${DEPEND}
+ >=sys-devel/clang-2.9"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7-fix_soname.patch
+
+ if ! use cxx;
+ then
+ sed -e 's/addtest_flags(CXXExceptions.*//' \
+ -i Test/CMakeLists.txt || die "test sed failed"
+ fi
+}
+
+src_configure() {
+ export CC=clang
+ export CXX=clang++
+
+ export PREFIX=/usr
+ local mycmakeargs=(
+ -DGNUSTEP_CONFIG=GNUSTEP_CONFIG-NOTFOUND
+ $(cmake-utils_use boehm-gc BOEHM_GC)
+ $(cmake-utils_use_enable cxx OBJCXX)
+ $(cmake-utils_use test TESTS)
+ )
+ cmake-utils_src_configure
+}