summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-11-14 20:13:53 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-11-14 20:13:53 +0000
commita5b1f1c2f40eb04faab9331ff5112c17627ea6ca (patch)
tree83b7c104b4a81e218b058f78a91f9c622833d513 /gnustep-apps
parentMaintenance release bump, ebuild cleanup (diff)
downloadgentoo-2-a5b1f1c2f40eb04faab9331ff5112c17627ea6ca.tar.gz
gentoo-2-a5b1f1c2f40eb04faab9331ff5112c17627ea6ca.tar.bz2
gentoo-2-a5b1f1c2f40eb04faab9331ff5112c17627ea6ca.zip
Maintenance release bump, ebuild cleanup
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/gnumail/ChangeLog7
-rw-r--r--gnustep-apps/gnumail/gnumail-1.2.0.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/gnustep-apps/gnumail/ChangeLog b/gnustep-apps/gnumail/ChangeLog
index 677d1d7d3c78..428f77891137 100644
--- a/gnustep-apps/gnumail/ChangeLog
+++ b/gnustep-apps/gnumail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-apps/gnumail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gnumail/ChangeLog,v 1.33 2011/06/06 09:09:49 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gnumail/ChangeLog,v 1.34 2011/11/14 20:13:53 voyageur Exp $
+
+*gnumail-1.2.0 (14 Nov 2011)
+
+ 14 Nov 2011; Bernard Cafarelli <voyageur@gentoo.org> +gnumail-1.2.0.ebuild:
+ Maintenance release bump, ebuild cleanup
06 Jun 2011; Bernard Cafarelli <voyageur@gentoo.org>
gnumail-1.2.0_pre3-r1.ebuild:
diff --git a/gnustep-apps/gnumail/gnumail-1.2.0.ebuild b/gnustep-apps/gnumail/gnumail-1.2.0.ebuild
new file mode 100644
index 000000000000..c8b336d7216b
--- /dev/null
+++ b/gnustep-apps/gnumail/gnumail-1.2.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gnumail/gnumail-1.2.0.ebuild,v 1.1 2011/11/14 20:13:53 voyageur Exp $
+
+EAPI=4
+inherit gnustep-2
+
+MY_P=${P/gnum/GNUM}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.collaboration-world.com/gnumail/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="crypt +emoticon +xface"
+DEPEND="~gnustep-libs/pantomime-${PV}
+ >=gnustep-base/gnustep-gui-0.11.0
+ || ( gnustep-apps/addresses gnustep-libs/addresseskit )"
+RDEPEND="crypt? ( app-crypt/gnupg )"
+
+src_prepare() {
+ sed -i -e 's|GNUMail_GUI_LIBS =|LIBRARIES_DEPEND_UPON +=|' \
+ Framework/GNUMail/GNUmakefile || die "as-needed sed failed"
+}
+
+src_compile() {
+ egnustep_env
+ egnustep_make
+
+ cd Bundles/Clock
+ egnustep_make
+ cd "${S}"
+
+ if use xface ; then
+ cd Bundles/Face
+ egnustep_make
+ cd "${S}"
+ fi
+
+ if use crypt ; then
+ cd Bundles/PGP
+ egnustep_make
+ cd "${S}"
+ fi
+
+ if use emoticon ; then
+ cd Bundles/Emoticon
+ egnustep_make
+ cd "${S}"
+ fi
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd Bundles/Clock
+ egnustep_install
+ cd "${S}"
+
+ if use xface ; then
+ cd Bundles/Face
+ egnustep_install
+ cd "${S}"
+ fi
+ if use crypt ; then
+ cd Bundles/PGP
+ egnustep_install
+ cd "${S}"
+ fi
+ if use emoticon ; then
+ cd Bundles/Emoticon
+ egnustep_install
+ cd "${S}"
+ fi
+
+ dodoc "${S}"/Documentation/*
+}