summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-02-10 10:02:18 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-02-10 10:02:18 +0000
commit711dcc540c7a34c14c6682a02849ee160343e9a5 (patch)
tree61fe9702cfc29c958d75dd4a1ab8ad3a0f8aa6d6 /gnustep-apps
parentVersion bump, bugfix release (diff)
downloadgentoo-2-711dcc540c7a34c14c6682a02849ee160343e9a5.tar.gz
gentoo-2-711dcc540c7a34c14c6682a02849ee160343e9a5.tar.bz2
gentoo-2-711dcc540c7a34c14c6682a02849ee160343e9a5.zip
Version bump, adds autocomplete and projectcenter plugin
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/gemas/ChangeLog10
-rw-r--r--gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch24
-rw-r--r--gnustep-apps/gemas/gemas-0.4.ebuild45
-rw-r--r--gnustep-apps/gemas/metadata.xml3
4 files changed, 80 insertions, 2 deletions
diff --git a/gnustep-apps/gemas/ChangeLog b/gnustep-apps/gemas/ChangeLog
index c05dac13755b..33a19dc1c245 100644
--- a/gnustep-apps/gemas/ChangeLog
+++ b/gnustep-apps/gemas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-apps/gemas
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gemas/ChangeLog,v 1.2 2012/06/07 20:12:03 xmw Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gemas/ChangeLog,v 1.3 2014/02/10 10:02:18 voyageur Exp $
+
+*gemas-0.4 (10 Feb 2014)
+
+ 10 Feb 2014; Bernard Cafarelli <voyageur@gentoo.org> +gemas-0.4.ebuild,
+ +files/gemas-0.4-bundle_makefile.patch, metadata.xml:
+ Version bump, adds autocomplete and projectcenter plugin
07 Jun 2012; Michael Weber <xmw@gentoo.org> gemas-0.3.ebuild:
marking ~ppc (bug 410601)
diff --git a/gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch b/gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch
new file mode 100644
index 000000000000..73595f256b56
--- /dev/null
+++ b/gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch
@@ -0,0 +1,24 @@
+diff -Naur Gemas-0.4.orig/Bundle/Gemas/GNUmakefile Gemas-0.4/Bundle/Gemas/GNUmakefile
+--- Gemas-0.4.orig/Bundle/Gemas/GNUmakefile 2013-12-24 18:51:16.000000000 +0100
++++ Gemas-0.4/Bundle/Gemas/GNUmakefile 2014-02-10 10:50:45.331011111 +0100
+@@ -10,7 +10,7 @@
+ BUNDLE_NAME = Gemas
+ BUNDLE_EXTENSION = .editor
+ Gemas_PRINCIPAL_CLASS = GemasEditor
+-Gemas_INSTALL_DIR=$(GNUSTEP_LOCAL_APPS)/ProjectCenter.app/Resources
++Gemas_INSTALL_DIR=${DESTDIR}/$(GNUSTEP_SYSTEM_APPS)/ProjectCenter.app/Resources
+
+ #
+ # Additional libraries
+diff -Naur Gemas-0.4.orig/Bundle/Gemas/GNUmakefile.preamble Gemas-0.4/Bundle/Gemas/GNUmakefile.preamble
+--- Gemas-0.4.orig/Bundle/Gemas/GNUmakefile.preamble 2013-12-24 18:51:16.000000000 +0100
++++ Gemas-0.4/Bundle/Gemas/GNUmakefile.preamble 2014-02-10 10:50:50.622016109 +0100
+@@ -15,7 +15,7 @@
+ ADDITIONAL_LDFLAGS +=
+
+ # Additional include directories the compiler should search
+-ADDITIONAL_INCLUDE_DIRS +=-I$(GNUSTEP_LOCAL_HEADERS)/ProjectCenter
++ADDITIONAL_INCLUDE_DIRS +=-I$(GNUSTEP_SYSTEM_HEADERS)/ProjectCenter
+
+ # Additional library directories the linker should search
+ ADDITIONAL_LIB_DIRS += -L./HighlighterKit/HighlighterKit.framework
diff --git a/gnustep-apps/gemas/gemas-0.4.ebuild b/gnustep-apps/gemas/gemas-0.4.ebuild
new file mode 100644
index 000000000000..95eb7fc0e910
--- /dev/null
+++ b/gnustep-apps/gemas/gemas-0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gemas/gemas-0.4.ebuild,v 1.1 2014/02/10 10:02:18 voyageur Exp $
+
+EAPI=5
+inherit eutils gnustep-2
+
+MY_P=${P/g/G}
+DESCRIPTION="a simple code editor for GNUstep"
+HOMEPAGE="http://wiki.gnustep.org/index.php/Gemas.app"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="projectcenter"
+
+DEPEND=">=gnustep-libs/highlighterkit-0.1.2
+ >=virtual/gnustep-back-0.22.0
+ projectcenter? ( gnustep-apps/projectcenter )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-bundle_makefile.patch
+}
+
+src_compile() {
+ gnustep-base_src_compile
+ if use projectcenter;
+ then
+ cd Bundle/Gemas || die "compile cd failed"
+ egnustep_make
+ fi
+}
+
+src_install() {
+ gnustep-base_src_install
+ if use projectcenter;
+ then
+ cd Bundle/Gemas || die "install cd failed"
+ egnustep_install
+ fi
+}
diff --git a/gnustep-apps/gemas/metadata.xml b/gnustep-apps/gemas/metadata.xml
index 1427f2847412..5fcc88f636fc 100644
--- a/gnustep-apps/gemas/metadata.xml
+++ b/gnustep-apps/gemas/metadata.xml
@@ -3,4 +3,7 @@
<pkgmetadata>
<herd>gnustep</herd>
<longdescription>Gemas is a simple code editor for GNUstep. It have autoindentation and highlight syntax for C, C++, Objective-C, Objective-C++, GSmarkup. And to edit Strings, Plist, GNUmakefile, ChangeLog files and plain text files (INSTALL, README, ...)</longdescription>
+ <use>
+ <flag name='projectcenter'>Build and install plugin for <pkg>gnustep-apps/projectcenter</pkg></flag>
+ </use>
</pkgmetadata>