summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-10-04 15:45:13 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-10-04 15:45:13 +0000
commitdcbdab6806efcae9bccccac4dd34e4acc3c2c3ce (patch)
tree6b5334c4939eb1092df5898779d4cdc69785b6fc /gnome-extra
parentLocalize CPPFLAGS before appending to it -- prevent it from leaking out of th... (diff)
downloadgentoo-2-dcbdab6806efcae9bccccac4dd34e4acc3c2c3ce.tar.gz
gentoo-2-dcbdab6806efcae9bccccac4dd34e4acc3c2c3ce.tar.bz2
gentoo-2-dcbdab6806efcae9bccccac4dd34e4acc3c2c3ce.zip
Clean up the at-spi2-atk compatible revision and update it to python-r1.eclass.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/at-spi/ChangeLog9
-rw-r--r--gnome-extra/at-spi/at-spi-1.32.0-r2.ebuild74
-rw-r--r--gnome-extra/at-spi/at-spi-1.32.0.ebuild8
3 files changed, 87 insertions, 4 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index 31b37add7745..f7048dafb3d0 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.236 2013/07/28 18:05:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.237 2013/10/04 15:45:13 tetromino Exp $
+
+*at-spi-1.32.0-r2 (04 Oct 2013)
+
+ 04 Oct 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ at-spi-1.32.0.ebuild, +at-spi-1.32.0-r2.ebuild:
+ Clean up the at-spi2-atk compatible revision and update it to
+ python-r1.eclass.
*at-spi-2.8.0 (28 Jul 2013)
diff --git a/gnome-extra/at-spi/at-spi-1.32.0-r2.ebuild b/gnome-extra/at-spi/at-spi-1.32.0-r2.ebuild
new file mode 100644
index 000000000000..7681a0c87d69
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-1.32.0-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.32.0-r2.ebuild,v 1.1 2013/10/04 15:45:13 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/atk-1.29.2
+ >=x11-libs/gtk+-2.19.7:2
+ >=gnome-base/libbonobo-1.107
+ >=gnome-base/orbit-2
+ >=dev-libs/dbus-glib-0.76
+ >=gnome-base/gconf-2
+ dev-libs/popt
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/inputproto
+ x11-proto/xproto
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am
+
+# needs a live properly configured environment. Not really suited to
+# an ebuild restricted environment
+RESTRICT="test"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ # relocate must be explicitely set
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ --enable-sm \
+ --enable-relocate \
+ --disable-xevie
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/reference/html"
+}
diff --git a/gnome-extra/at-spi/at-spi-1.32.0.ebuild b/gnome-extra/at-spi/at-spi-1.32.0.ebuild
index bc55bd23557c..bd61a5933c55 100644
--- a/gnome-extra/at-spi/at-spi-1.32.0.ebuild
+++ b/gnome-extra/at-spi/at-spi-1.32.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.32.0.ebuild,v 1.9 2012/05/05 06:25:18 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.32.0.ebuild,v 1.10 2013/10/04 15:45:13 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -28,7 +28,9 @@ RDEPEND=">=dev-libs/atk-1.29.2
x11-libs/libSM
x11-libs/libX11
x11-libs/libXi
- x11-libs/libXtst"
+ x11-libs/libXtst
+
+ !app-accessibility/at-spi2-atk"
DEPEND="${RDEPEND}
virtual/pkgconfig